This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 711703 - can't create a VM
can't create a VM
Status: CLOSED DUPLICATE of bug 678555
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-08 04:39 EDT by Ferry Huberts
Modified: 2011-06-10 12:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 11:15:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2011-06-08 04:39:50 EDT
Description of problem:
Can't create a VM of CentOS 5.6 64

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start virt-manager
2. create a new virtual machine
3. fill in name (gittest), click forward
4. select iso of centos 5.6 64, os linux, version rhel 5.4 or later, press forward
5. 1024MB ram, 2 cpus, forward
6. select managed storage, precreated qcow2 file, forward
7. finish
  
Actual results:
Unable to complete install: 'Unable to create cgroup for gittest: No such file or directory'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1643, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1187, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1246, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 1346, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: Unable to create cgroup for gittest: No such file or directory


Expected results:
success

Additional info:
selinux enforcing, disabling selinux has no effect
Comment 1 Ferry Huberts 2011-06-08 04:41:33 EDT
libvirt.x86_64                                       0.8.8-4.fc15  
libvirt-client.x86_64                                0.8.8-4.fc15  
libvirt-python.x86_64                                0.8.8-4.fc15  
perl-Sys-Virt.x86_64                                 0.2.6-2.fc15  
python-virtinst.noarch                               0.500.6-2.fc15
python-virtkey.x86_64                                0.50-9.fc15   
virt-manager.noarch                                  0.8.7-4.fc15  
virt-top.x86_64                                      1.0.5-2.fc15  
virt-v2v.x86_64                                      0.7.0-2.fc15  
virt-viewer.x86_64                                   0.3.1-1.fc15  
virt-what.x86_64                                     1.10-1.fc15
Comment 2 Ferry Huberts 2011-06-08 11:15:53 EDT
this problems manifests on my freshly installed T60 machine.

it does not manifest on my upgraded (from F14) thinkcentre machine, which has the same packages:
libvirt.x86_64                                       0.8.8-4.fc15  
libvirt-client.x86_64                                0.8.8-4.fc15  
libvirt-python.x86_64                                0.8.8-4.fc15  
perl-Sys-Virt.x86_64                                 0.2.6-2.fc15  
python-virtinst.noarch                               0.500.6-2.fc15
python-virtkey.x86_64                                0.50-9.fc15   
virt-manager.noarch                                  0.8.7-4.fc15  
virt-top.x86_64                                      1.0.5-2.fc15  
virt-v2v.x86_64                                      0.7.0-2.fc15  
virt-viewer.x86_64                                   0.3.1-1.fc15  
virt-what.x86_64                                     1.10-1.fc15   


weird

did a reboot of the t60 machine and now it works.
weird again.
Comment 3 Cole Robinson 2011-06-10 12:37:48 EDT
This is caused by systemd purging cgroups. if you see it again, a work around is 'service libvirtd restart'

*** This bug has been marked as a duplicate of bug 678555 ***

Note You need to log in before you can comment on or make changes to this bug.