Bug 711767 - yumdownloader is trying to download the package again from another repo
Summary: yumdownloader is trying to download the package again from another repo
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 711768
TreeView+ depends on / blocked
 
Reported: 2011-06-08 12:39 UTC by Karel Srot
Modified: 2014-01-21 06:23 UTC (History)
3 users (show)

(edit)
Clone Of:
: 711768 (view as bug list)
(edit)
Last Closed: 2012-06-20 13:54:21 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0858 normal SHIPPED_LIVE yum-utils bug fix and enhancement update 2012-06-19 20:48:23 UTC

Description Karel Srot 2011-06-08 12:39:14 UTC
Description of problem:

When the (latest version of the) package is available in more repos, after the package is downloaded, yumdownloader is trying to downloaded it again from another repo.

# rm -f aide-0.14-3.el6.x86_64.rpm
# yumdownloader aideLoaded plugins: rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
aide-0.14-3.el6.x86_64.rpm
       | 125 kB     00:00     
./aide-0.14-3.el6.x86_64.rpm already exists and appears to be complete

This is because

# yum --showduplicates list aide
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Available Packages
aide.x86_64          0.14-3.el6       rhel6
aide.x86_64          0.14-3.el6       test  


Version-Release number of selected component (if applicable):
yum-utils-1.1.30-6.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. set up one repo twice (use different id)
2. try to download a package
  
Actual results:
./aide-0.14-3.el6.x86_64.rpm already exists and appears to be complete

Expected results:
When the package is downloaded, yumdownloader doesn't try to download it again

Bug applies for RHEL5 too

Comment 6 errata-xmlrpc 2012-06-20 13:54:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0858.html


Note You need to log in before you can comment on or make changes to this bug.