Bug 7119 - Can't use NIS module with Python
Can't use NIS module with Python
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-18 17:46 EST by James Graves
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-22 12:50:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Graves 1999-11-18 17:46:38 EST
I can't import and use the NIS module with Python 1.5.2.  This is what it
looks like trying it from the interactive prompt:

# python
Python 1.5.2 (#1, Nov 18 1999, 16:29:32)  [GCC egcs-2.91.66 19990314/Linux
(egcs- on linux-i386
Copyright 1991-1995 Stichting Mathematisch Centrum, Amsterdam
>>> import nis
Traceback (innermost last):
  File "<stdin>", line 1, in ?
ImportError: /usr/lib/python1.5/lib-dynload/nismodule.so: undefined
symbol: yperr_string


I've looked at the definition of /usr/include/rpcsvc/ypclnt.h and
yperr_string is indeed in there.  I don't do much with dynamically loaded
libraries, so I'm not sure where to go from here.
Comment 1 Michael K. Johnson 1999-11-22 12:50:59 EST
nismodule needed to be linked with -lnsl
Fixed in python-1.5.2-8 package which will be in the next RawHide
release.  Please re-open this bug if that is not the case.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.