Bug 71191 - rpm-4.1-0.75.src.rpm fails to recompile with gcc-2.96-112
rpm-4.1-0.75.src.rpm fails to recompile with gcc-2.96-112
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-09 15:12 EDT by Michael Phillips, Jr.
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 15:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Phillips, Jr. 2002-08-09 15:12:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
rpm-4.1-0.75.src.rpm fails to recompile with gcc-2.96-112.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild rpm-4.1-0.75.src.rpm
2.
3.
	

Actual Results:  rpminstall.c: In function `rpmInstallSource':
rpminstall.c:805: parse error before `rpmrc'
rpminstall.c:806: `rpmrc' undeclared (first use in this function)
rpminstall.c:806: (Each undeclared identifier is reported only once
rpminstall.c:806: for each function it appears in.)
rpminstall.c:789: warning: `rc' might be used uninitialized in this function
make[3]: *** [rpminstall.lo] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/rpm-4.1/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/rpm-4.1/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/rpm-4.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.62464 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.62464 (%build)

Expected Results:  Since there is no restriction on the gcc compiler build, the
source rpm should recompile without error.

Additional info:

Using the following patch allows gcc-2.96-112 to compile rpminstall.c without error:
--- rpm-4.1/lib/rpminstall.c	2002-08-09 14:48:50.000000000 -0400
+++ rpm-4.1/lib/rpminstall.c.changes	2002-08-09 14:49:32.000000000 -0400
@@ -787,6 +787,7 @@
 {
     FD_t fd;
     int rc;
+    rpmRC rpmrc;
 
 
     fd = Fopen(arg, "r.ufdio");
@@ -802,7 +803,7 @@
     {
 	rpmVSFlags ovsflags;
 	ovsflags = rpmtsSetVSFlags(ts, (rpmtsVSFlags(ts) | RPMVSF_NEEDPAYLOAD));
-
rpmRC rpmrc = rpmInstallSourcePackage(ts, fd, specFilePtr, cookie);
+
rpmrc = rpmInstallSourcePackage(ts, fd, specFilePtr, cookie);
 	rc = (rpmrc == RPMRC_OK ? 0 : 1);
 	ovsflags = rpmtsSetVSFlags(ts, ovsflags);
     }
Comment 1 Jeff Johnson 2002-08-10 11:23:34 EDT
Fixed in rpm-4.1-0.76

Note You need to log in before you can comment on or make changes to this bug.