Bug 711970 - path_selector in multipathd default configure is 'selector'
path_selector in multipathd default configure is 'selector'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.7
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Ben Marzinski
Gris Ge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-09 03:06 EDT by Gris Ge
Modified: 2012-02-21 01:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:35:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2011-06-09 03:06:41 EDT
Description of problem:
We have this line in defaults section of multipathd default configuration;
======
selector "round-robin 0"
======
But, in device sections, we are using this one:
======
path_selector "round-robin 0"
======

Base on my assumption, they are the same, but they might confuse our customer.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.7-42.el5_6.3

How reproducible:
100%

Steps to Reproduce:
1. service multipathd start
2. multipathd -k'show config'
3. Check the selector in defaults section and path_selector in devices section.
  
Actual results:
multipathd are providing different name for path_selector in configuration.

Expected results:
multipathd using the same name of it. For back compatibility, we may still support selector keyword.

Additional info:
Comment 1 RHEL Product and Program Management 2011-06-21 01:33:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.7 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 4 Ben Marzinski 2011-10-11 18:56:18 EDT
Both "selector" and "path_selector" will now work.
Comment 6 Gris Ge 2012-01-11 02:16:31 EST
"show config" output of multipathd are providing "path_selector" now in device-mapper-multipath-0.4.7-48.el5 

"selector" keyword are still functionally. RHEL 5 only has 1 selector - "round-robin 0", no future test needed.


VERIFY.
Comment 7 errata-xmlrpc 2012-02-21 01:35:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0166.html

Note You need to log in before you can comment on or make changes to this bug.