Bug 711998 - s390utils-iucvterm should depend on grep
s390utils-iucvterm should depend on grep
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.1
s390x Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Horák
qe-baseos-daemons
:
Depends On:
Blocks: 691780
  Show dependency treegraph
 
Reported: 2011-06-09 04:56 EDT by Jan Stodola
Modified: 2011-12-06 12:44 EST (History)
3 users (show)

See Also:
Fixed In Version: s390utils-1.8.2-37.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:44:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2011-06-09 04:56:40 EDT
Description of problem:
Package s390utils-iucvterm uses 'grep' in postinstall/postuninstall scriplets,
but the package doesn't depend on the grep package:

[root@rtt6 ~]# rpm -q --scripts s390utils-iucvterm | grep grep
grep -q '^/usr/bin/ts-shell$' /etc/shells \
    grep -v '^/usr/bin/ts-shell$' /etc/shells > /etc/shells.ts-new
[root@rtt6 ~]# rpm -qf /bin/grep
grep-2.6.3-2.el6.s390x
[root@rtt6 ~]# rpm -q --requires s390utils-iucvterm | grep grep
[root@rtt6 ~]#


[root@rtt6 ~]# yum --installroot=/root/new_install_root install s390utils-iucvterm
Loaded plugins: product-id, subscription-manager
Updating Red Hat repositories.
rhel                           | 4.0 kB     00:00     
rhel/primary_db                | 2.5 MB     00:00     
Setting up Install Process

...

  Installing : audit-libs-2.1-5.el6.s390x                         22/24 
  Installing : 2:shadow-utils-4.1.4.2-9.el6.s390x                 23/24 
  Installing : 2:s390utils-iucvterm-1.8.2-36.el6.s390x            24/24 
/var/tmp/rpm-tmp.Ppyo3H: line 2: grep: command not found
rhel/productid                                    | 1.7 kB     00:00     
duration: 9(ms)
Installed products updated.
...

Version-Release number of selected component (if applicable):
RHEL 6.1 GA
s390utils-iucvterm-1.8.2-36.el6.s390x

How reproducible:
always

Steps to Reproduce:
1. see description
  
Actual results:
s390utils-iucvterm doesn't depend on grep, there should be error messages during installation of the package

Expected results:
s390utils-iucvterm depends grep
Comment 4 errata-xmlrpc 2011-12-06 12:44:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1525.html

Note You need to log in before you can comment on or make changes to this bug.