Bug 712027 - No postscriptdriver tags any more
No postscriptdriver tags any more
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-cups (Show other bugs)
15
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 712074
  Show dependency treegraph
 
Reported: 2011-06-09 06:06 EDT by Tim Waugh
Modified: 2011-06-15 01:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-cups-1.9.57-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-15 01:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2011-06-09 06:06:30 EDT
Description of problem:
All the postscriptdriver tags have disappeared from the gutenprint-cups package.

Version-Release number of selected component (if applicable):
gutenprint-cups-5.2.7-1.fc15

How reproducible:


Steps to Reproduce:
1.rpm -q gutenprint-cups --provides | grep postscriptdriver
  
Actual results:
No output.

Expected results:
Lots of tags.

Additional info:
Last known good: gutenprint-5.2.6-3.fc15
Comment 1 Tim Waugh 2011-06-09 06:26:06 EDT
Here's the reason:

Processing files: gutenprint-cups-5.2.7-2.fc15.x86_64
/builddir/build/BUILDROOT/gutenprint-5.2.7-2.fc15.x86_64/usr/lib/cups/driver/gutenprint.5.2: error while loading shared libraries: libgutenprint.so.2: cannot open shared object file: No such file or directory
Comment 2 Tim Waugh 2011-06-09 08:14:11 EDT
Underlying cause: the postscriptdriver.prov script is no longer given $RPM_BUILD_ROOT as its first command line argument, but is instead given it as an environment variable.
Comment 3 Fedora Update System 2011-06-09 08:53:19 EDT
python-cups-1.9.57-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-cups-1.9.57-1.fc15
Comment 4 Fedora Update System 2011-06-11 00:31:40 EDT
Package python-cups-1.9.57-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-cups-1.9.57-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-cups-1.9.57-1.fc15
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-06-15 01:51:26 EDT
python-cups-1.9.57-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.