This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 712165 - Upgraded Satellite fails to include /tmp/pre_install_network_config during re-provisioning [NEEDINFO]
Upgraded Satellite fails to include /tmp/pre_install_network_config during re...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
540
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2011-06-09 12:46 EDT by Brian Harrington
Modified: 2014-03-03 19:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-13 12:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cperry: needinfo? (bharrington)


Attachments (Terms of Use)

  None (edit)
Description Brian Harrington 2011-06-09 12:46:13 EDT
Description of problem:

After performing a satellite upgrade from 5.3 to 5.4 on new hardware, attempting to re-provision a server against satellite using an imported kickstart fails.  

This is due to a failure to include the stanza "%include /tmp/pre_install_network_config" in the main section of the kickstart file.


How reproducible:


Steps to Reproduce:
1. Perform satellite upgrade as per documentation (satellite and os upgrade)
2. Select server in satellite
3. Click the "provisioning" tab
4. Select the old kickstart from the list
5. Select "advanced options"
6. Chose to do a static install pulling the network configuration of eth0
7. rhn_check on the client system
8. reboot
  
Actual results:
The system will hang before executing a retrieval of the stage 2 image complaining of an inability to see the randomized location used for tracking the provisioning process.

Expected results:
An uneventful install resulting in the box rebooting and sitting at a command prompt.

Additional info:

When creating a new kickstart file and utilizing this, re-provisioning happens as expected.  Perhaps some check needs to be done to look for the inclusion of a "network" line or searching for the existence of /tmp/pre_install_network_config
Comment 1 Brian Harrington 2011-06-09 13:12:20 EDT
Client informs that that kickstart files in 5.3 did not require the "network" box to be checked in for using re-provisioning to work.

Upon checking the network box within the advanced options of the kickstart, the file renders properly.

Regardless of this, all of the network information supplied by cobbler is still being parsed and placed into the file "/tmp/pre_install_network_config".  Is this sane?  Also, does it make sense to even allow a re-provision without the "network" option enabled?
Comment 2 Brian Harrington 2011-06-09 13:12:58 EDT
Also, missing the "network" options still works fine in a PXE install of the file provided via tftp via cobbler.

Note You need to log in before you can comment on or make changes to this bug.