Bug 712271 - (ghc-fclabels) Review Request: ghc-fclabels - A package that provides first class accessor labels
Review Request: ghc-fclabels - A package that provides first class accessor l...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
notready
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-10 00:25 EDT by Narasimhan
Modified: 2013-06-24 06:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 06:25:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Narasimhan 2011-06-10 00:25:02 EDT
Spec file  : http://narasim.fedorapeople.org/package_reviews/ghc-fclabels.spec

SRPM file : http://narasim.fedorapeople.org/package_reviews/ghc-fclabels-0.11.1.1-1.fc14.src.rpm

Koji build : http://koji.fedoraproject.org/koji/taskinfo?taskID=3122646

rpmlint output:
ghc-fclabels.i686: W: spelling-error Summary(en_US) accessor -> accessory, access or, access-or
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels.i686: W: spelling-error %description -l en_US composable -> com posable, com-posable, compo sable
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels.src: W: spelling-error Summary(en_US) accessor -> accessory, access or, access-or
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels.src: W: spelling-error %description -l en_US composable -> com posable, com-posable, compo sable
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels-devel.i686: W: spelling-error Summary(en_US) accessor -> accessory, access or, access-or
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels-devel.i686: W: spelling-error %description -l en_US composable -> com posable, com-posable, compo sable
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels-prof.i686: E: devel-dependency ghc-fclabels-devel
Your package has a dependency on a devel package but it's not a devel package
itself.

ghc-fclabels-prof.i686: W: spelling-error Summary(en_US) accessor -> accessory, access or, access-or
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels-prof.i686: W: spelling-error %description -l en_US composable -> com posable, com-posable, compo sable
The value of this tag appears to be misspelled. Please double-check.

ghc-fclabels-prof.i686: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

ghc-fclabels-prof.i686: W: devel-file-in-non-devel-package /usr/lib/ghc-7.0.2/fclabels-0.11.1.1/libHSfclabels-0.11.1.1_p.a
A development file (usually source code) is located in a non-devel package. If
you want to include source code in your package, be sure to create a
development package.

4 packages and 1 specfiles checked; 1 errors, 10 warnings.

Required for yi.
Comment 1 Narasimhan 2012-09-09 03:23:51 EDT
ghc-pointed-list > v4.0  requires fclabels.However yi works with ghc-pointed-list <v4.0.

I will keep this review open.
Comment 2 Jens Petersen 2012-12-11 03:00:47 EST
http://packdeps.haskellers.com/reverse/fclabels
Comment 3 Jens Petersen 2013-06-24 06:25:01 EDT
Closing out old Haskell Package Reviews that use deprecated macros
like %ghc_devel_package, etc, which are no longer available in F20 Rawhide.  Please update your package using cabal-rpm-0.8.x or later and re-open
or file a new Review Request.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.