Bug 71238 - no display during boot after grub menu with geforce 3
no display during boot after grub menu with geforce 3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-10 15:32 EDT by Tom Dean
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Dean 2002-08-10 15:32:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020508
Netscape6/6.2.3

Description of problem:
I installed a new nVidia GeForce 3 based video board and after selecting a
kernel from the GRUB menu, my display goes completely black when it boots the
kernel (2.4.18-5 i686); however, my monitor's signal LED stays green and does
not switch to amber, which would otherwise indicate video signal loss.  The
video board is sending a blank signal to the monitor once Linux starts. I was
using the nVidia driver for X --previous video card was an older GeForce 256 DDR
 - no need to change drivers-- and after a while, X/KDM would start and I had a
functional system; just no video between POST/GRUB menu and X. Seems like once
the nVidia compiled module NVdriver was loaded, the display initialized.    
Changed XFree86 driver from nVidia release 1.0.2960 to generic "nv" driver - X
does not start -- machine is set to start in run level 5.  Hard drive keeps
loading the OS, however no console is available. Tried switching through vttys -
no display.  Tried modifying/forcing IRQs for AGP/PCI in BIOS to assign an IRQ
to the GeForce 3 that isn't being shared by ACPI--still fails. Machine boots
/video initializes with older GeForce 256.  Also booted with an ATI Radeon 64
DDR--no problem.  

Version-Release number of selected component (if applicable):
2.4.18-5 i686

How reproducible:
Always

Steps to Reproduce:
1.Power down system
2.Install GeForce 3 video board
3.Power up, watch display disappear as Linux boots
	

Expected Results:  I'm supposed to be able to see the display

Additional info:

Motherboard: ASUS CUSL2 BIOS rev 1009
CPU: Pentium III 933 MHz
Memory: 512 MB 
Video Board: VisionTek Xtasy 6964 GeForce 3 Ti 500 64 MB DDR AGP
Comment 1 Jeff Iddings 2002-08-17 16:23:20 EDT
Using ASUS A7V266, Duron 750MHZ, GeForce2 MX -- 

Have experienced same problem...

Tried different kernels from Rawhide, including .i386, .i586, and .athlon
packages.  Using Lilo, not Grub.

System boots when using custom kernel compiled from kernel.org.

Comment 2 Bill Nottingham 2003-02-19 11:44:07 EST
Does this work better with rawhide grub?
Comment 3 Jeff Iddings 2003-02-19 14:57:49 EST
No, tried Grub from Rawhide.. same problems.
Comment 4 Tom Dean 2003-02-19 23:41:11 EST
2/19/03
Here's some info for a work around -- 
I passed the 'nofb' argument to the kernel in grub.conf to disable the 
framebuffer at boot time and it fixed the disappearing display. 
Apparently the framebuffer modes in RH kernels don't support this particular 
GeForce 3 board (?).  Please respond to let me know if you guys have any 
success with this fix.  Thanks!

Tom
tomdean@myactv.net 

example line from grub.conf:
kernel /vmlinuz hdd=ide-scsi nofb  
Comment 5 Jeff Iddings 2003-02-20 12:44:33 EST
Added the nofb option to Grub..  same results.

Comment 6 Tom Dean 2003-03-06 23:01:43 EST
Have NOT experienced the problem in Red Hat BETA 8.0.94 (Phoebe)
Everything seems to be working fine.

Using ABIT KT7A BIOS A9
CPU: AMD Athlon T-Bird 1.4 GHz
512 MB RAM
VisionTek Xtasy 6964 GeForce 3 Ti 500 64 MB DDR AGP 4X

Will test on the ASUS CUSL2 w/ Pentium III 933
Comment 7 Bugzilla owner 2004-09-30 11:39:50 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.