Bug 71239 - up2date-2.9.38-7.x.9 needs more explicit dependencies
up2date-2.9.38-7.x.9 needs more explicit dependencies
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-08-10 15:50 EDT by Kris Urquhart
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-10 15:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kris Urquhart 2002-08-10 15:50:38 EDT
Description of Problem:
I upgraded up2date from 2.9.33-7.x.9, but when I tried to run it I got
unresolved dependencies:

[root@oscar root]# up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 18, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 28, in ?
    import gpgUtils
  File "/usr/share/rhn/up2date_client/gpgUtils.py", line 17, in ?
    _ts = transaction.initReadOnlyTransaction()
  File "/usr/share/rhn/up2date_client/transaction.py", line 62, in
  File "/usr/share/rhn/up2date_client/transaction.py", line 51, in pushVSFlags

I then upgraded rpm to 4.1-0.75 (not sure what it was before), and tried again:

[root@oscar root]# up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/python2.2/site-packages/rpmmodule.so: undefined symbol:

Upgrading rpm-python to 4.1-0.75 (was 4.1-0.69) fixed this last problem.

up2date does properly depend on both rpm and rpm-python, but they also need some
>= conditionals added.

Version-Release number of selected component (if applicable):

How Reproducible:
Didn't try.

Steps to Reproduce:
1.  upgrade up2date without upgrading rpm and rpm-python

Actual Results:
unresolved symbols

Expected Results:
up2date upgrade should have required upgrading rpm and rpm-python

Additional Information:
Comment 1 Adrian Likins 2002-08-12 14:41:39 EDT
I'll add a more specific rpm version require, since for
the betas at least, the rpm versions change alot.

Note You need to log in before you can comment on or make changes to this bug.