Bug 712415 - maybe subscription-manager list --consumed and --installed should show a consistent label for the Subscription/SerialNumber
maybe subscription-manager list --consumed and --installed should show a cons...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-10 09:59 EDT by John Sefler
Modified: 2011-12-06 12:15 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:15:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-06-10 09:59:15 EDT
Description of problem:
A call to "subscription-manager list --consumed produces this sample output:
[root@jsefler-stage-6server tmp]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Red Hat Enterprise Linux Scalable File System (for RHEL Server)
ContractNumber:     	2010464                  
AccountNumber:      	477931                   
SerialNumber:       	3320217395539403903      
Active:             	True                     
Begins:             	10/05/2010               
Expires:            	10/04/2011   

A call to "subscription-manager list --installed" or "subscription-manager list" produces this sample output:
[root@jsefler-stage-6server tmp]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Scalable File System (for RHEL Server)
Status:             	Subscribed               
Expires:            	10/04/2011               
Subscription:       	3320217395539403903      
ContractNumber:     	2010464                  
AccountNumber:      	477931     


Notice that the "SerialNumber" and "Subscription" field represent the same value.  We could be consistent and label it the same thing.  I'd suggest using the "SerialNumber" label since the unsubscribe command uses option --serial to specify this number.


Version-Release number of selected component (if applicable):
This has been present in subscription-manager since early development of the project.
Comment 2 Bryan Kearney 2011-07-18 15:21:12 EDT
fixed in 0f1e23a81472808c9a0fc68c30b752d8750e894c in master.
Comment 3 John Sefler 2011-07-19 14:57:50 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.40.158de0a.el6.x86_64


[root@jsefler-onprem-62server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Awesome OS Scalable Filesystem Bits
ContractNumber:     	2                        
AccountNumber:      	12331131231              
SerialNumber:       	5945536885441836861      
Active:             	True                     
QuantityUsed:       	1                        
Begins:             	07/18/2011               
Expires:            	07/17/2012               

[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Awesome OS Scalable Filesystem Bits
Status:             	Subscribed               
Expires:            	07/17/2012               
SerialNumber:       	5945536885441836861      
ContractNumber:     	2                        
AccountNumber:      	12331131231   


^^^^
SerialNumber is now used in both list reports.
Comment 4 errata-xmlrpc 2011-12-06 12:15:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.