Bug 7125 - Problems recording CD-R's
Problems recording CD-R's
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-18 20:31 EST by stilpaul
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 18:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stilpaul 1999-11-18 20:31:49 EST
I've been having problems getting my CD-Recorder to work under RH 6.1 It
was fine under 6.0.  I contacted the authors of the software that I use
(cdrecord & xcdroast) and they said that it looks like a bug in the kernel
scsi code.  I include below both e-mails with the details of the problem.

Paul Stillwell
stilpaul@home.com
stilpaul@hotmail.com

From - Thu Nov 18 20:13:02 1999
Return-Path: <schilling@fokus.gmd.de>
Received: from h4.mail.home.com ([24.0.0.57]) by mail.rdc2.on.home.com
          (InterMail v4.01.01.07 201-229-111-110) with ESMTP
          id
<19991118182252.IVAR8251.mail.rdc2.on.home.com@h4.mail.home.com>
          for <stilpaul@mail.mtwx1.on.wave.home.com>;
          Thu, 18 Nov 1999 10:22:52 -0800
Received: from mx3-w.mail.home.com (mx3-w.mail.home.com [24.0.0.53])
	by h4.mail.home.com (8.9.3/8.9.0) with ESMTP id JAA01720
	for <stilpaul@home.com>; Thu, 18 Nov 1999 09:37:10 -0800 (PST)
From: schilling@fokus.gmd.de
Received: from mailhub.fokus.gmd.de (mailhub.fokus.gmd.de [193.174.154.14])
	by mx3-w.mail.home.com (8.9.1/8.9.1) with ESMTP id JAA29456
	for <stilpaul@home.com>; Thu, 18 Nov 1999 09:36:56 -0800 (PST)
Received: from burner.fokus.gmd.de (burner [193.175.133.116])
	by mailhub.fokus.gmd.de (8.8.8/8.8.8) with ESMTP id SAA13077;
	Thu, 18 Nov 1999 18:36:33 +0100 (MET)
Received: (from jes@localhost)
	by burner.fokus.gmd.de (8.9.3+Sun/8.9.3) id TAA01228;
	Thu, 18 Nov 1999 19:36:30 +0100 (MET)
Date: Thu, 18 Nov 1999 19:36:30 +0100 (MET)
Message-Id: <199911181836.TAA01228@burner.fokus.gmd.de>
To: schilling@fokus.gmd.de, stilpaul@home.com, tn@fh-muenchen.de
Subject: Re: Not sure if the prob is cdrecord or Xcdroast
X-Mozilla-Status: 8011
X-Mozilla-Status2: 00000000
X-UIDL: <199911181836.TAA01228@burner.fokus.gmd.de>


This is an impossible error.

There must be a bug in the sg.c code in the kernel.
Try to use a different Linux kernel.


>From stilpaul@home.com Thu Nov 18 05:34:53 1999

>    Like the title says, I'm not sure where the problem lies, however, I
>think it is in cdrecord.

>I'm using a vanilla RedHat 6.1 install on a P200 with 64 Meg Ram and a
>1.6 Mb H-disk.  I have a Matsushita cw-7502 burner,  a Toshiba 12x cd
>drive, and an Advansys SCSI card (IOMEGA Jazz Jet).  Things worked when
>I was running RedHat 6.0, however, I nuked and reinstalled with RH 6.1
>and now things don't work.  I nuked and installed Windoze98 and Easy
>CD-Creator and things worked.  I re-installed RH 6.1 and now they don't
>again <sigh>.  I'm sorry, but I really don't have much to go on other
>than the output from each of the programs.  I've looked for obvious
>things like it's a bad CD, but I've tried several from a manufacturer
>that I've had good success with (sony), and after failing under linux,
>they worked under Windoze.  Oh... I've verified that all of the SCSI
>connections are OK and re-seated the SCSI card.  Any help is
>appreciated.

>Thanx
>                Paul


>Here's the logfile recorded by Xcdroast (defined on the setup panel):

>Nov 17 23:57:06 XCDR 0.96e: Setup: Configuration saved
>Nov 17 23:57:11 XCDR 0.96e: entering Master-CD
>Nov 17 23:57:20 XCDR 0.96e: Write-Image from /burn/image1.raw, 250673152
>bytes, dummy=0
>Nov 17 23:57:20 XCDR 0.96e: Executing:
>/usr/lib/xcdroast-0.96e/bin/cdrecord-1.6.1 -v speed=2 dev=0,05,00 -eject
>-data /burn/image1.raw
>Nov 17 23:58:23 XCDR 0.96e: Write-Image: Some error occured


>Here is the output from cdrecord (as distributed with RH6.1), the output
>was identical to the output from the version distributed with Xcdroast:

>[root@george /root]# cdrecord -v speed=4 dev=0,05,00 -eject -data
>/burn/image1.r
>aw
>Cdrecord release 1.8a29 Copyright (C) 1995-1999 Jvrg Schilling
>TOC Type: 1 = CD-ROM
>scsidev: '0,05,00'
>scsibus: 0 target: 5 lun: 0
>Using libscg version 'schily-0.1'
>atapi: 0
>Device type    : Removable CD-ROM
>Version        : 2
>Response Format: 2
>Capabilities   : SYNC LINKED
>Vendor_info    : 'MATSHITA'
>Identifikation : 'CD-R   CW-7502  '
>Revision       : '4.10'
>Device seems to be: Matsushita CW-7502.
>Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
>Driver flags   : SWABAUDIO
>Drive buf size : 1044288 = 1019 KB
>FIFO size      : 4194304 = 4096 KB
>Track 01: data  239 MB
>Total size:     274 MB (27:12.01) = 122401 sectors
>Lout start:     274 MB (27:14/01) = 122401 sectors
>Current Secsize: 2048
>ATIP info from disk:
>  Indicated writing power: 5
>  Is not unrestricted
>  Is not erasable
>  ATIP start of lead in:  -11689 (97:26/11)
>  ATIP start of lead out: 335550 (74:36/00)
>Disk type: Long strategy type (Cyanine, AZO or similar)
>Manuf. index: 19
>Manufacturer: POSTECH Corporation
>Blocks total: 335550 Blocks current: 335550 Blocks remaining: 213149
>Starting to write CD/DVD at speed 4 in write mode for single session.
>Last chance to quit, starting real write in 1 seconds.
> Waiting for reader process to fill input-buffer ... input-buffer ready.

>Starting new track at sector: 0
>Track 01:   0 of 239 MB written.cdrecord: Input/output error. write_g1:
>scsi sen
>dcmd: no error
>CDB:  2A 00 00 00 01 20 00 00 10 00
>status: 0x0 (GOOD STATUS)
>cmd finished after 13.013s timeout 40s

>write track data: error after 589824 bytes
>Sense Bytes: 70 00 00 00 00 00 00 0A 00 00 00 00 00 00 00 00 00 00
>cdrecord: Input/output error. flush cache: scsi sendcmd: retryable error

>CDB:  35 00 00 00 00 00 00 00 00 00
>status: 0x2 (CHECK CONDITION)
>Sense Bytes: 70 00 02 00 00 00 00 0A 00 00 00 00 04 01 00 00
>Sense Key: 0x2 Not Ready, Segment 0
>Sense Code: 0x04 Qual 0x01 (logical unit is in process of becoming
>ready) Fru 0x
>0
>Sense flags: Blk 0 (not valid)
>cmd finished after 0.003s timeout 120s
>Trouble flushing the cache
>Writing  time:   19.145s
>Fixating...
>cdrecord: Input/output error. close track/session: scsi sendcmd:
>retryable error
>CDB:  5B 00 02 00 00 00 00 00 00 00
>status: 0x2 (CHECK CONDITION)
>Sense Bytes: 70 0002 00 00 00 00 0A 00 00 00 00 04 01 00 00
>Sense Key: 0x2 Not Ready, Segment 0
>Sense Code: 0x04 Qual 0x01 (logical unit is in process of becoming
>ready) Fru 0x
>0
>Sense flags: Blk 0 (not valid)
>cmd finished after 0.003s timeout 480s
>Fixating time:   27.399s
>cdrecord: fifo had 146 puts and 19 gets.
>cdrecord: fifo was 0 times empty and 10 times full, min fill was 98%.



Jvrg

 EMail:joerg@schily.isdn.cs.tu-berlin.de (home) Jvrg Schilling D-13353
Berlin
       js@cs.tu-berlin.de		(uni)  If you don't have iso-8859-1
       schilling@fokus.gmd.de		(work) chars I am J"org Schilling
 URL:  http://www.fokus.gmd.de/usr/schilling
ftp://ftp.fokus.gmd.de/pub/unix
________________________________________________________________________

From - Thu Nov 18 20:13:19 1999
Return-Path: <tn@bv.rz.fh-muenchen.de>
Received: from mx5-rwc.mail.home.com ([24.0.95.34])
          by mail.rdc2.on.home.com (InterMail v4.01.01.07 201-229-111-110)
          with ESMTP
          id
<19991118093155.KUP8251.mail.rdc2.on.home.com@mx5-rwc.mail.home.com>
          for <stilpaul@mail.mtwx1.on.wave.home.com>;
          Thu, 18 Nov 1999 01:31:55 -0800
Received: from mx3-rwc.mail.home.com (mx3-rwc.mail.home.com [24.0.95.32])
	by mx5-rwc.mail.home.com (8.9.3/8.9.0) with ESMTP id BAA09205
	for <stilpaul@home.com>; Thu, 18 Nov 1999 01:20:18 -0800 (PST)
Received: from mailhost.fh-muenchen.de (mailhost.fh-muenchen.de
[129.187.244.204])
	by mx3-rwc.mail.home.com (8.9.1/8.9.1) with ESMTP id BAA25773
	for <stilpaul@home.com>; Thu, 18 Nov 1999 01:20:17 -0800 (PST)
Received: from bv.rz.fh-muenchen.de (bv.rz.fh-muenchen.de [129.187.244.81])
	by mailhost.fh-muenchen.de (8.9.1a/8.8.7) with ESMTP id KAA27295
	for <stilpaul@home.com>; Thu, 18 Nov 1999 10:11:08 +0100 (MET)
Received: (from tn@localhost)
	by bv.rz.fh-muenchen.de (8.9.1a/8.8.7) id KAA11955;
	Thu, 18 Nov 1999 10:20:13 +0100 (MET)
Message-ID: <19991118102013.39476@bv.rz.fh-muenchen.de>
Date: Thu, 18 Nov 1999 10:20:13 +0100
From: Thomas Niederreiter <tn@tarantel.rz.fh-muenchen.de>
To: Paul Stillwell <stilpaul@home.com>
Subject: Re: Not sure if the prob is cdrecord or Xcdroast
References: <38338216.135F19FC@home.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
X-Mailer: Mutt 0.79e
In-Reply-To: <38338216.135F19FC@home.com>; from Paul Stillwell on Wed, Nov
17, 1999 at 11:35:34PM -0500
X-Mozilla-Status: 8011
X-Mozilla-Status2: 00000000
X-UIDL: <19991118102013.39476@bv.rz.fh-muenchen.de>

On Wed, Nov 17, 1999 at 11:35:34PM -0500, Paul Stillwell wrote:
> Hi,
>
>     Like the title says, I'm not sure where the problem lies, however, I
> think it is in cdrecord.
>
> I'm using a vanilla RedHat 6.1 install on a P200 with 64 Meg Ram and a
> 1.6 Mb H-disk.  I have a Matsushita cw-7502 burner,  a Toshiba 12x cd
> drive, and an Advansys SCSI card (IOMEGA Jazz Jet).  Things worked when
> I was running RedHat 6.0, however, I nuked and reinstalled with RH 6.1
> and now things don't work.  I nuked and installed Windoze98 and Easy
> CD-Creator and things worked.  I re-installed RH 6.1 and now they don't
> again <sigh>.  I'm sorry, but I really don't have much to go on other
> than the output from each of the programs.  I've looked for obvious
> things like it's a bad CD, but I've tried several from a manufacturer
> that I've had good success with (sony), and after failing under linux,
> they worked under Windoze.  Oh... I've verified that all of the SCSI
> connections are OK and re-seated the SCSI card.  Any help is
> appreciated.

Looks like the kernel-driver of your scsi-card is causing problems...
Perhaps see if there are any compile-options for the scsi-driver and
tweak there a little.
No idea otherwise.

Good luck,

Thomas

  ___ ___
 /   |   \  ___________   | REAL   : Thomas Niederreiter: Munich, Germany
/    ~    \/  _ \_  __ \  | EMAIL  : tn@mailserv.rz.fh-muenchen.de
\    Y    (  <_> )  | \/  | MUD/IRC: Hor/_Hor
 \___|_  / \____/|__|     |
       \/ All I want is a warm bed and a kind word and unlimited
power
                      -- Ashleigh Brilliant
Comment 1 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 2 Alan Cox 2002-12-13 20:31:09 EST
Many things were fixed in both the scsi burners and kernel (and stuff like
workarounds for bad drives). In the absence of more info I plan to close this bug.
If it still happens after all this time - reopen it and let me know
Comment 3 Stephen John Smoogen 2003-01-23 18:29:47 EST
Bug 7125 has been closed due to Red Hat Linux 6.0/6.1 is no longer supported by
Red Hat. This bug looks to have been fixed in the current Red Hat Linux (I cant
duplicate it in 7.3 with similar hardware.)

Note You need to log in before you can comment on or make changes to this bug.