Bug 71267 - Installer does not setup xfree86 with 3d hardware acceleration with ati all-in-wonder 128
Installer does not setup xfree86 with 3d hardware acceleration with ati all-i...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-11 12:56 EDT by A.D. Shackelford
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 10:49:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A.D. Shackelford 2002-08-11 12:56:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
The installs from 7.3 and both limbo betas do not appear to setup the 3d 
hardware acceleration when using a normal ati all-in-wonder 128 card. It 
configures 2d just fine, but glxinfo still reports Mesa GLX Indirect. It also
does not install the kernel r128 module either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use at all-in-wonder r128 card, with tyan motherboard and optiquest v95 monitor.
2. Perform normal RH Linux install with XFree86 setup.
3. lsmod does not report r128 loaded and glxinfo reports indirect renderer.
	

Actual Results:  Same results through 7.3 and both limbo betas.

Expected Results:  glxinfo to report using hardware acceleration, and 3d games
(tux racer) and screensavers to have good performance.

Additional info:

'rpm -qa | grep XFree'
XFree86-libs-4.2.0-56
XFree86-font-utils-4.2.0-56
XFree86-75dpi-fonts-4.2.0-56
XFree86-Mesa-libGL-4.2.0-56
XFree86-xfs-4.2.0-56
XFree86-truetype-fonts-4.2.0-56
XFree86-100dpi-fonts-4.2.0-56
XFree86-base-fonts-4.2.0-56
XFree86-4.2.0-56
XFree86-twm-4.2.0-56
XFree86-xdm-4.2.0-56
XFree86-Mesa-libGLU-4.2.0-56
XFree86-xauth-4.2.0-56
XFree86-tools-4.2.0-56
XFree86-devel-4.2.0-56

'glxinfo'
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 Mesa 3.4.2
OpenGL extensions:

'uname -a'
Linux c3po 2.4.18-7.80 #1 Tue Jul 23 18:20:11 EDT 2002 i686 unknown unknown
GNU/Linux

XF86config
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "dri"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
EndSection
Section "DRI"
        Mode 0666
EndSection
Comment 1 Mike A. Harris 2002-08-12 05:58:06 EDT
That wouldn't be an XFree86 bug.  3D acceleration works in XFree86 fine.
Reassigning to anaconda.

Please indicate what brand/speed/type of CPU you have also, and the
output of "uname -a" please.
Comment 2 Jeremy Katz 2002-08-12 10:14:05 EDT
Also, how much video ram do you have and what resolution/bit depth did you
select to run at?  Including the full /etc/X11/XF86Config-4 file helps quite a bit
Comment 3 A.D. Shackelford 2002-08-12 19:02:23 EDT
'uname -a' (was included above)
Linux c3po 2.4.18-7.80 #1 Tue Jul 23 18:20:11 EDT 2002 i686 unknown unknown
GNU/Linux

Processor: Intel PIII 750mhz Coppermine
Video Info: ATI All-in-wonder 128 w/16mb display ram

Display settings: 1600x1200/24 bit mode (millions of colors)

Since this is the second limbo beta Ive included /etc/X11/XF86Config (the v4
default). 
------------------

# File generated by anaconda.

Section "ServerLayout"
        Identifier     "Anaconda Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
	InputDevice	"Mouse1" "SendCoreEvents"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath	"/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

    FontPath   "unix/:7100"

EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
	Load  "fbdevhw"
	Load  "dri"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"

#	Option	"AutoRepeat"	"500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
#	Option	"Protocol"	"Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
	Option	"XkbRules"	"xfree86"
	Option	"XkbModel"	"pc105"
	Option	"XkbLayout"	"us"
	#Option	"XkbVariant"	""
	#Option	"XkbOptions"	""
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection


Section "InputDevice"
	Identifier	"Mouse1"
	Driver		"mouse"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"IMPS/2"
	Option		"Emulate3Buttons"	"no"
	Option		"ZAxisMapping"		"4 5"
EndSection


Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync   30-95
        VertRefresh 50-150
        Option "dpms"

	
EndSection

Section "Device"
	# no known options
	Identifier   "ATI Rage 128"
        Driver       "r128"
        VendorName   "ATI Rage 128"
        BoardName     "ATI Rage 128"
        
        #BusID
EndSection

Section "Screen"
	Identifier   "Screen0"
        Device       "ATI Rage 128"
        Monitor      "Monitor0"
	DefaultDepth	24

	Subsection "Display"
        	Depth       24
                Modes       "1600x1200" "1600x1200" 
	EndSubsection

EndSection

Section "DRI"
	Mode 0666
EndSection
---------------------------------------
Comment 4 Jeremy Katz 2002-08-13 00:48:28 EDT
Could you include your /var/log/XFree86.0.log file?
Comment 5 Mike A. Harris 2002-08-13 03:43:40 EDT
Rage 128 3D acceleration only works in 16bit depth IIRC.
The log file will indicate this.

My initial assumption (and reason for reassigning...) was I thought
anaconda chose an i386 kernel (which has no DRI support).  Probably
wrong on that now...
Comment 6 Mike A. Harris 2002-08-13 06:51:20 EDT
>configures 2d just fine, but glxinfo still reports Mesa GLX Indirect. It also
>does not install the kernel r128 module either.

Aha, my assumption was right.  ;o)

Anaconda should never install an i386 kernel.  ;O)

Comment 7 A.D. Shackelford 2002-08-13 10:49:34 EDT
Changing the bit depth to 16bit activated the 3d extensions. (thanks guys)
If the 3d extension is related to ram on card and bit depth-
Should there be a dialog window or notice on the Xconfig portion of anaconda
stating such?

ex: 'Due to the amount of ram on your video card, the bit depth you selected
will not enable 3d hardware extensions. Please select a lower bit depth, if you
want to enable this feature.'
Comment 8 Jeremy Katz 2002-08-13 11:42:46 EDT
There's another bug report (don't remember the # offhand, it's deferred for now)
about making the xconfig process make you more aware of implications for DRI.

Note You need to log in before you can comment on or make changes to this bug.