Bug 71276 - up2date uses X11 info dialog
up2date uses X11 info dialog
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-11 16:14 EDT by Jim Wright
Modified: 2015-01-07 18:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 14:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Wright 2002-08-11 16:14:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
"/usr/sbin/up2date -u" should do its job without the need for any sort of X11
interaction.  however, when the load is high and the free service is cut off,
the above command attempts to inform the user of this with a graphical dialog box.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ssh to remote server using user account
2.use "su" to become root
3.run "/usr/sbin/up2date -u" when free service is not available
	

Additional info:

up2date-2.7.61-7.x.2
Comment 1 Adrian Likins 2002-08-12 15:20:21 EDT
If it can talk to X, it shows a X dialog, if
it cant, it shows a text dialog.
Comment 2 Jim Wright 2002-08-13 04:36:46 EDT
nice in theory, but that is not what happened.  the process running as root
could not use the X forwarding of my user-level ssh connection.  but when it
came time to display the info stating that "server unavailable, too many
connections, freebies get bumped", instead it croaked with unable to establish X
connection.  which is why I filed the bugzilla - you describe what I believe
ought to happen, but it did not.
Comment 3 Adrian Likins 2002-08-13 15:15:10 EDT
wouldnt happen to have a traceback?
Comment 4 Jim Wright 2002-08-13 20:00:50 EDT
just tried now, and by chance the free server is full.  here's what I see:

% /usr/sbin/up2date -u
X11 connection rejected because of wrong authentication.
Gdk-ERROR **: X connection to localhost:10.0 broken (explicit kill or server
shutdown).


if I run this locally, then X works and I can see the long error message
displayed in an X dialog.  I won't copy it all, but it starts:

Error Message:
  Free service limited due to high load, please try to again later (server
1000280024)
Error Class Code: 51
Error Class Info:
 [...]
Explanation:
 [...]

for completeness' sake, the locally run instance also spits out some stuff
related to X, but is still able to throw up the above dialog.  the messages
appear prior to the X dialog being realized, and they are:

% /usr/sbin/up2date -u

GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified
are supported and host-based authentication failed.
Comment 5 Jim Wright 2002-12-03 15:32:37 EST
I use the following command, which works around the problem for me.  I think the
code ought to check whether it can connect to the X server, and not just test if
the DISPLAY environment variable is set.  But this isn't a big deal, and I
easily work around it.  OK by me to have this one closed.

DISPLAY="" /usr/sbin/up2date -u
Comment 6 Adrian Likins 2003-01-20 22:34:17 EST
Should be cleaned up in cvs head. Recent versions 3.x should
handle this nicely.
Comment 7 Matt Jamison 2003-05-22 14:41:54 EDT
resolving bug.

Note You need to log in before you can comment on or make changes to this bug.