Bug 71279 - rpm -F --nobuild doesn't work
rpm -F --nobuild doesn't work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-11 16:31 EDT by Stephen Rasku
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-11 16:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2002-08-11 16:31:40 EDT
Description of Problem:

In the man page for rpm, --nobuild option is listed under the install and
upgrade options as:

    Do not install the package, simply  check  for  and report potential 
    conflicts.

However, it reports an error message if you try and use it.

Version-Release number of selected component (if applicable):

rpm-4.0.4-7x

How Reproducible:

100%


Steps to Reproduce:
1. rpm -Fvh --nobuild XFree86-4.2.0-61.4.i386.rpm

Actual Results:

--nobuild: unknown option

Expected Results:

According to the man page, it should check for conflicts but it shouldn't
install.  However, it looks like this is a documentation problem.  --nobuild
should be replaced by --test in the man page.
Comment 1 Jeff Johnson 2002-08-12 12:57:44 EDT
From the rpm-4.1 man page:
... 
 install-options
        [--allfiles] [--badreloc] [--excludepath OLDPATH]
        [--excludedocs] [--force] [-h,--hash]
        [--ignoresize] [--ignorearch] [--ignoreos]
        [--includedocs] [--justdb] [--nodeps]
        [--nodigest] [--nosignature] [--nosuggest]
        [--noorder] [--noscripts] [--notriggers]
        [--oldpackage] [--percent] [--prefix NEWPATH]
        [--relocate OLDPATH=NEWPATH]
        [--repackage] [--replacefiles] [--replacepkgs]
        [--test]
...
       --test Do not install the package, simply  check  for  and
              report potential conflicts.


...

Comment 2 Stephen Rasku 2002-08-12 16:59:38 EDT
I don't know how fussy you are about your resolutions but this should really be
resolved RAWHIDE since the latest offical rpm version (rpm-4.0.4-7x) is
documented incorrectly.  

Also, rpm 4.1 is not available from the rawhide directory.  It only seems to go
up to m*.  Was there a build problem today?

Note You need to log in before you can comment on or make changes to this bug.