Bug 712807 - [abrt] scsi-target-utils-1.0.14-2.el6: __list_del: Process /usr/sbin/tgtd was killed by signal 11 (SIGSEGV)
Summary: [abrt] scsi-target-utils-1.0.14-2.el6: __list_del: Process /usr/sbin/tgtd was...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils
Version: 6.1
Hardware: x86_64
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard: abrt_hash:ccc4b979e4421c0aebc6f4ce75f...
: 699585 721387 736367 (view as bug list)
Depends On:
Blocks: 742640
TreeView+ depends on / blocked
 
Reported: 2011-06-13 08:47 UTC by David Jaša
Modified: 2011-12-17 13:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 742640 833526 (view as bug list)
Environment:
Last Closed: 2011-12-06 18:58:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: backtrace (3.33 KB, text/plain)
2011-06-13 08:47 UTC, David Jaša
no flags Details
fix (956 bytes, patch)
2011-09-29 23:13 UTC, Andy Grover
no flags Details | Diff
targets.conf (6.60 KB, application/octet-stream)
2011-12-17 13:17 UTC, Flos Lonicerae
no flags Details
part of /var/log/messages (1.97 KB, application/octet-stream)
2011-12-17 13:17 UTC, Flos Lonicerae
no flags Details
show how to trigger the bug (14.63 MB, video/ogg)
2011-12-17 13:24 UTC, Flos Lonicerae
no flags Details
try to format a iscsi storage shared by RHEL6 in windows 2003 server (74.76 KB, image/jpeg)
2011-12-17 13:27 UTC, Flos Lonicerae
no flags Details
tgtd debug log (41.85 KB, application/octet-stream)
2011-12-17 13:27 UTC, Flos Lonicerae
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1762 0 normal SHIPPED_LIVE scsi-target-utils bug fix and enhancement update 2011-12-06 01:01:30 UTC

Description David Jaša 2011-06-13 08:47:20 UTC
abrt version: 1.1.16
architecture: x86_64
Attached file: backtrace, 3411 bytes
cmdline: tgtd
component: scsi-target-utils
Attached file: coredump, 32759808 bytes
crash_function: __list_del
executable: /usr/sbin/tgtd
kernel: 2.6.32-131.2.1.el6.x86_64
package: scsi-target-utils-1.0.14-2.el6
rating: 4
reason: Process /usr/sbin/tgtd was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux Server release 6.1 (Santiago)
Attached file: sosreport.tar.xz, 1735304 bytes
time: 1307953147
uid: 0

comment
-----
* occured only with some provided targets, without apparent reason
* occured on older kernels, too (-71)

How to reproduce
-----
1. 
2. 
3.

Comment 1 David Jaša 2011-06-13 08:47:23 UTC
Created attachment 504393 [details]
File: backtrace

Comment 5 Andy Grover 2011-09-29 21:41:51 UTC
*** Bug 721387 has been marked as a duplicate of this bug. ***

Comment 6 Andy Grover 2011-09-29 21:43:12 UTC
can reproduce, working on it.

Comment 7 Andy Grover 2011-09-29 23:13:12 UTC
Created attachment 525658 [details]
fix

this patch is against development tip but should also apply to 1.0.14.

Comment 8 Andy Grover 2011-09-30 00:40:14 UTC
*** Bug 736367 has been marked as a duplicate of this bug. ***

Comment 9 Andy Grover 2011-10-03 23:14:36 UTC
*** Bug 699585 has been marked as a duplicate of this bug. ***

Comment 11 Barry Donahue 2011-10-17 18:11:10 UTC
Verified SanityOnly.

Comment 12 Flos Lonicerae 2011-10-28 09:19:55 UTC
Package: scsi-target-utils-1.0.18-2.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
service tgtd restart

Comment 13 errata-xmlrpc 2011-12-06 18:58:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1762.html

Comment 14 Flos Lonicerae 2011-12-16 05:35:31 UTC
i recompile scsi-target-utils 1.0.14-4.el6 by myself and installed on my RHEL6.0 test machine, the problem still exists!
i will upload a detailed steps later.

another thing is that storages shared by scsi-target-utils can NOT be used by Windows 2003, both setting storage to removable type or not.
but setting storage type to removable can be made use by Windows XP. some earlier related discussion can be found here:
http://lists.wpkg.org/pipermail/stgt/2009-February/002631.html

Comment 15 Flos Lonicerae 2011-12-17 13:17:15 UTC
Created attachment 548199 [details]
targets.conf

Comment 16 Flos Lonicerae 2011-12-17 13:17:54 UTC
Created attachment 548200 [details]
part of /var/log/messages

Comment 17 Flos Lonicerae 2011-12-17 13:24:04 UTC
Created attachment 548205 [details]
show how to trigger the bug

Comment 18 Flos Lonicerae 2011-12-17 13:27:23 UTC
Created attachment 548206 [details]
try to format a iscsi storage shared by RHEL6 in windows 2003 server

it says "due to an internal error, operation cancelled"

Comment 19 Flos Lonicerae 2011-12-17 13:27:48 UTC
Created attachment 548207 [details]
tgtd debug log


Note You need to log in before you can comment on or make changes to this bug.