Bug 71284 - GRUB returns error code 21 during stage 1.5 when trying to boot XP/RH 7.3
GRUB returns error code 21 during stage 1.5 when trying to boot XP/RH 7.3
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-11 18:49 EDT by Alan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My device.map file... (101 bytes, patch)
2002-08-18 21:51 EDT, Alan
no flags Details | Diff
device.map file, as requested... (101 bytes, patch)
2002-08-18 22:01 EDT, Alan
no flags Details | Diff

  None (edit)
Description Alan 2002-08-11 18:49:34 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux) 
 
Description of problem: 
I bought a brand new Dell Dimension 8200 with Windows XP home edition 
installed on a 40Gb IDE hard drive (with 2 partitions - a 31mb Dell partition 
with utilities and boot info, and the other partition is the XP partition). 
 
I installed a second IDE HD (15Gb) for linux. I setup 12Gb for Linux and 3Gb 
for the Swap Partition. 
 
I chose GRUB for my boot loader during the RedHat 7.3 installation process and 
when my pc starts up, I get a screen with Grub at stage 1.5 and error code 21 
returned.  
 
I did not re-format or re-partition my first drive (the Dell/XP drive), but I 
did re-partition and format my Linux drive. I can boot Linux properly from the 
emergency boot disk (from floppy), but since XP is using NTFS I can't read any 
of the files off of that Drive (to at least salvage some data on there). 
 
My hard drive configuration (as reported by the Hardware Browser) is as 
follows... 
 
device=/dev/hda 
partition(name, start, end, size, type)=hda1, 1, 4, 31, None 
partition=hda2, 5, 4865, 38131, ntfs 
device=/dev/hdb 
partition=hdb1, 1, 1529, 11994, ext3 
partition=hdb2, 1530, 1868, 2659, linux-swap 
 
my /boot/grub/grub.conf file looks like... 
# grub.conf generated by anaconda 
# 
# Note that you do not have to rerun grub after making changes to this file 
# NOTICE:  You do not have a /boot partition.  This means that 
#          all kernel and initrd paths are relative to /, eg. 
#          root (hd1,0) 
#          kernel /boot/vmlinuz-version ro root=/dev/hdb1 
#          initrd /boot/initrd-version.img 
#boot=/dev/hda 
default=0 
timeout=10 
splashimage=(hd1,0)/boot/grub/splash.xpm.gz 
title WinXp 
 rootnoverify (hd0,1) 
 chainloader +1 
title Red Hat Linux (2.4.18-3) 
 root (hd1,0) 
 kernel /boot/vmlinuz-2.4.18-3 ro root=/dev/hdb1 hdd=ide-scsi 
 initrd /boot/initrd-2.4.18-3.img 
 
What's wrong? 
 
Also - a side question - is there any way I can get my linux installation to 
recognize the ntfs file system with my xp files (particularly my mp3 music??). 
 
 
Thanks in advance for your help!! 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.Modified the grub.conf file 
2.Rebooted 
3. 
  
 
Actual Results:  Same problem as described above. 
 
Expected Results:  Expected GRUB to boot correctly. 
 
Additional info: 
 
My PC is brand new so there's not much data on it that i want to salvage on 
the XP partition. However, the Linux drive that I formatted was copied over to 
the XP drive so i could have a backup copy of all the files I wanted just in 
case. Now, since I can't even get to the XP drive through Linux (or any other 
means), my old data is inaccessible!!! I might be forced to re-install XP just 
to have a bootable ntfs system and then do a re-install of linux again. I 
don't even know if thatwould help anything!
Comment 1 Jeremy Katz 2002-08-18 13:21:10 EDT
Error 21 is "device doesn't exist" -- what are the contents of your
/boot/grub/device.map file?
Comment 2 Alan 2002-08-18 21:51:42 EDT
Created attachment 71387 [details]
My device.map file...
Comment 3 Alan 2002-08-18 22:01:31 EDT
Created attachment 71388 [details]
device.map file, as requested...
Comment 4 Jeremy Katz 2002-09-20 16:38:17 EDT
Is there an updated bios available for the 8200?  The only way you should get
that message via code inspection is if the bios access of the drive is failing
for some reason
Comment 5 Jeremy Katz 2002-10-31 18:22:31 EST
Closing due to lack of activity.  Please reopen if you have further information.
Comment 6 Red Hat Bugzilla 2006-02-21 13:49:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.