Bug 712886 - perl-App-Asciio keyboard shortcuts don't work and the file saved in a binary
Summary: perl-App-Asciio keyboard shortcuts don't work and the file saved in a binary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Gtk2
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-13 13:40 UTC by prayther
Modified: 2011-09-15 19:35 UTC (History)
5 users (show)

Fixed In Version: perl-Gtk2-1.224-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-08 07:09:28 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CPAN 68813 None None None Never

Description prayther 2011-06-13 13:40:10 UTC
Description of problem:

Having loaded perl-App-Asciio (plus asciio) and it's dependencies.  Running app-asciio in fedora 15 gnome 3 on an x86_64 machine (not virtual), the keyboard shortcuts, as outlined in app-asciio youtube video, do not work.

when i created a diagram using mouse commands and save the document, the resulting file was binary and was garbage when viewed from the CLI.

Version-Release number of selected component (if applicable):

asciio-1.02.71-8.fc15.noarch
perl-App-Asciio-1.02.71-8.fc15.noarch

How reproducible:

Open App-Asciio and try to use keyboard shortcuts and then creating and saving a document.

Steps to Reproduce:
1. Open App-Asciio
2. Try to use keyboard shortcuts (Ctrl F1, Ctrl t)
3. Save a document and the resulting file is seen as binary
  
Actual results:

-keyboard shortcuts do not work
-resulting file after saving appears to be binary versus ascii

Expected results:

-keyboard shortcuts work
-resulting file saved will be standards text/ascii

Additional info:

Comment 1 nadim khemir 2011-06-14 14:36:38 UTC
1/ the shortcuts do not work. I have had this error too when I upgraded
my system. This is not due to a change in Asciio but, I believe, in a
change in the gtk perl bindings which do not return the same key names
as they previously did. It would be interresting to know what output you got in the terminal you started asciio in. Usually non matching shortcuts are reported.

I have update the key names in my own installation but I haven't
released anything to fix it for other users. You can mail me and I'll
send the updated files. I will take this problem with the gtk-perl ppl
and this will be in the, long overdue, next release

2/ saved file is binary. It can't be looked at in the command line.

save you file with the right extension! .txt for a text file that you can cat or less. or .png for a screenshot

That is documented and shown in the screencasts too
http://www.youtube.com/watch?v=IiOHYNHo_Nw
http://www.youtube.com/watch?v=Vpth3yTT4Rs


It is pure luck I saw this error. It would be good if the bugs found where forwarded to the author (me in this case) packaging problems are outside my competence though.

Comment 2 prayther 2011-06-14 15:36:09 UTC
[aprayther@apray-chs-e6420 ~]$ asciio 
Using setup directory:'/usr/share/perl5/vendor_perl/App/Asciio/setup/'
no handler for input '000 + KEY_Control_L'.
no handler for input 'C00 + KEY_Alt_L'.

And while i was quite confident that i did try .txt as an extension, alas i must not have because it works great when i do.

if you could help me out with the "key control", that would be cool.

Comment 3 Iain Arnell 2011-08-12 09:51:17 UTC
This is certainly fixed on f16 with perl-Gtk2-1.223 where Gtk2 upstream changelog mentions "Cope with the rename of the keysym defines in gtk+ 2.22". And rebuilding rawhide's perl-Gtk2-1.224 locally on F15 fixes this for me. 

I also tested with dayplanner and found that it too has problems. With perl-Gtk2-1.203, ESC key doesn't work and "Use of uninitialized value in numeric eq (==) at /usr/bin/dayplanner line 2451" appears on console. With perl-Gtk2-1.224, it's also fine.

I think we probably just need to build perl-Gtk2-1.224 (or 1.223) for F15.

Comment 4 Fedora Update System 2011-08-22 17:28:28 UTC
perl-Gtk2-1.224-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/perl-Gtk2-1.224-1.fc15

Comment 5 Fedora Update System 2011-08-22 17:28:36 UTC
perl-Gtk2-1.224-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Gtk2-1.224-1.fc16

Comment 6 Fedora Update System 2011-08-22 18:35:48 UTC
Package perl-Gtk2-1.224-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Gtk2-1.224-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/perl-Gtk2-1.224-1.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-08-30 14:41:18 UTC
perl-Gtk2-1.224-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Gtk2-1.224-2.fc16

Comment 8 Fedora Update System 2011-08-30 14:41:32 UTC
perl-Gtk2-1.224-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Gtk2-1.224-2.el6

Comment 9 Fedora Update System 2011-08-30 14:41:44 UTC
perl-Gtk2-1.224-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/perl-Gtk2-1.224-2.fc15

Comment 10 Fedora Update System 2011-09-08 07:09:17 UTC
perl-Gtk2-1.224-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-09-09 17:13:47 UTC
perl-Gtk2-1.224-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-09-15 19:35:28 UTC
perl-Gtk2-1.224-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.