Bug 712941 - spicec --help should mention WAN features for Windows guests only
spicec --help should mention WAN features for Windows guests only
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client (Show other bugs)
6.2
Unspecified Linux
low Severity low
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-13 13:01 EDT by Swapna Krishnan
Modified: 2011-12-06 10:22 EST (History)
8 users (show)

See Also:
Fixed In Version: spice-client-0.8.2-1.el6
Doc Type: Bug Fix
Doc Text:
To prevent confusion and be more clear about spice-client WAN options (namely "color-depth" and "disable-effects"), spicec --help now specifically mentions that WAN options work only "(if supported by the guest vdagent)".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:22:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.66 KB, patch)
2011-07-07 04:13 EDT, Christophe Fergeau
no flags Details | Diff
The initial patch was buggy, fixed version (1.73 KB, patch)
2011-07-19 07:55 EDT, Christophe Fergeau
no flags Details | Diff

  None (edit)
Description Swapna Krishnan 2011-06-13 13:01:40 EDT
Description of problem:

Currently "spicec --help" mentions the WAN options but does not mention that they are applicable for Windows guests only.
Comment 2 Christophe Fergeau 2011-07-06 13:32:44 EDT
I'm not sure we should mentions that in --help in case linux guest/agent gain (some of) these features later on.
Comment 3 Swapna Krishnan 2011-07-06 13:35:18 EDT
If linux guest/agent gain these features at some point, then we can remove this message then. 

Thanks,
- Swapna
Comment 4 Christophe Fergeau 2011-07-07 03:05:06 EDT
The thing is, the client with these help messages and the guest with or without WAN features support may run on totally unrelated machines which are not upgraded at the same time. Maybe we can go with something like "(if supported by the guest vdagent)"? in --help
Comment 5 Christophe Fergeau 2011-07-07 04:13:11 EDT
Created attachment 511642 [details]
Proposed patch

Swapna, would such a description work for you? Feel free to suggest a different wording if this one sounds weird.
Comment 6 Christophe Fergeau 2011-07-18 12:36:25 EDT
This has been committed to spice git master
Comment 7 Christophe Fergeau 2011-07-19 07:55:36 EDT
Created attachment 513781 [details]
The initial patch was buggy, fixed version
Comment 8 Christophe Fergeau 2011-07-28 06:40:25 EDT
This bug fix is available in spice 0.8.2 which is being pushed to RHEL 6.2 , see https://brewweb.devel.redhat.com/buildinfo?buildID=173449 and https://brewweb.devel.redhat.com/buildinfo?buildID=174105
Comment 14 Bill Sanford 2011-09-20 14:57:02 EDT
This is fixed in 5.0.0.10018.


      --color-depth <16/32>
                              guest display color depth (if supported by the
                              guest vdagent)
      --disable-effects <wallpaper/font-smooth/animation/all,wallpaper/font-smoo
th/animation/all...>
                              disable guest display effects (if supported by
                              the guest vdagent)
Comment 15 Uri Lublin 2011-11-21 04:48:05 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
To prevent confusion and be more clear about spice-client WAN options (namely "color-depth" and "disable-effects"), spicec --help  now specifically mentions that WAN options work only "(if supported by the guest vdagent)".
Comment 16 errata-xmlrpc 2011-12-06 10:22:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1518.html

Note You need to log in before you can comment on or make changes to this bug.