Bug 712959 - [abrt] gdm-user-switch-applet-2.30.4-21.el6_0.1: Process /usr/libexec/gdm-user-switch-applet was killed by signal 6 (SIGABRT)
[abrt] gdm-user-switch-applet-2.30.4-21.el6_0.1: Process /usr/libexec/gdm-use...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
i686 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
abrt_hash:290f4a01705a81ce487bf75a24a...
:
Depends On:
Blocks: 782183 835616 863735 960054 840699
  Show dependency treegraph
 
Reported: 2011-06-13 14:18 EDT by Red Hat Case Diagnostics
Modified: 2013-11-21 18:31 EST (History)
5 users (show)

See Also:
Fixed In Version: gdm-2.30.4-43.el6
Doc Type: Bug Fix
Doc Text:
Cause: Logging in sporadically causes crash in user-switch applet Consequence: User is unable to user switch without reloading the applet Fix: Add checks in the code to prevent mutliple queued loads of user information from stomping over each other. Result: Applet is now more resiliant against crashes at startup.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.19 KB, text/plain)
2011-06-13 14:18 EDT, Red Hat Case Diagnostics
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 59150 None None None Never

  None (edit)
Description Red Hat Case Diagnostics 2011-06-13 14:18:19 EDT
This description generated by Andreas from an ABRT report
architecture: i686
cmdline: /usr/libexec/gdm-user-switch-applet --oaf-activate-iid=OAFIID:GNOME_FastUserSwitchApplet_Factory --oaf-ior-fd=28
component: gdm
executable: /usr/libexec/gdm-user-switch-applet
kernel: 2.6.32-131.2.1.el6.i686
package: gdm-user-switch-applet-2.30.4-21.el6_0.1
reason: Process /usr/libexec/gdm-user-switch-applet was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux Workstation release 6.1 (Santiago)
reproduce: 1.When I logged in
2.
3.

time: 1307988101
uid: 2011
backtrace: warning: core file may not match specified executable file.
[New Thread 2851]
[New Thread 2862]
[Thread debugging using libthread_db enabled]
Core was generated by `/usr/libexec/gdm-user-switch-applet --oaf-activate-iid=OAFIID:GNOME_FastUserSwi'.
Program terminated with signal 6, Aborted.
#0  0x00cbf424 in __kernel_vsyscall ()

Thread 2 (Thread 0xb74d6b70 (LWP 2862)):
#0  0x00cbf424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b756a4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00d1cf3f in ?? () from /lib/libgthread-2.0.so.0
No symbol table info available.
#3  0x00bb994c in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00bb9a66 in g_async_queue_timed_pop () from /lib/libglib-2.0.so.0
No symbol table info available.
#5  0x00c0ae5b in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00c098a0 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#7  0x00b719e9 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#8  0x00a840fe in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread 0xb771b870 (LWP 2851)):
#0  0x00cbf424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x009d0d71 in raise () from /lib/libc.so.6
No symbol table info available.
#2  0x009d264a in abort () from /lib/libc.so.6
No symbol table info available.
#3  0x00c062ff in g_assertion_message () from /lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00c0689e in g_assertion_message_expr () from /lib/libglib-2.0.so.0
No symbol table info available.
#5  0x08051873 in ?? ()
No symbol table info available.
#6  0x0805255f in ?? ()
No symbol table info available.
#7  0x00bdcdf2 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#8  0x00bdec78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#9  0x00be25e0 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#10 0x00be29ff in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#11 0x04a71ac4 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#12 0x04a6fc4f in bonobo_generic_factory_main_timeout () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#13 0x04a6fcd4 in bonobo_generic_factory_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#14 0x005c7f75 in panel_applet_factory_main_closure () from /usr/lib/libpanel-applet-2.so.0
No symbol table info available.
#15 0x005c805c in panel_applet_factory_main () from /usr/lib/libpanel-applet-2.so.0
No symbol table info available.
#16 0x0804cf92 in ?? ()
No symbol table info available.
#17 0x009bccc6 in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#18 0x0804cdb1 in ?? ()
No symbol table info available.
From        To          Syms Read   Shared Object Library
0x006706d0  0x006826d8  Yes (*)     /usr/lib/libdbus-glib-1.so.2
0x00389220  0x003b55e8  Yes (*)     /lib/libdbus-1.so.3
0x00b6f5e0  0x00b7b628  Yes (*)     /lib/libpthread.so.0
0x005c7440  0x005cd228  Yes (*)     /usr/lib/libpanel-applet-2.so.0
0x0086bf00  0x008895f8  Yes (*)     /usr/lib/libgconf-2.so.4
0x03f3b1d0  0x03f760d8  Yes (*)     /usr/lib/libbonoboui-2.so.0
0x052bae70  0x05591138  Yes (*)     /usr/lib/libgtk-x11-2.0.so.0
0x03e4e2f0  0x03eb3fa8  Yes (*)     /usr/lib/libgdk-x11-2.0.so.0
0x00d54bb0  0x00dc0398  Yes (*)     /lib/libgio-2.0.so.0
0x00444190  0x004569f8  Yes (*)     /usr/lib/libgdk_pixbuf-2.0.so.0
0x00533210  0x0058d328  Yes (*)     /usr/lib/libcairo.so.2
0x003ff180  0x00421178  Yes (*)     /usr/lib/libpango-1.0.so.0
0x04a6c320  0x04a9cb78  Yes (*)     /usr/lib/libbonobo-2.so.0
0x04996080  0x0499f238  Yes (*)     /usr/lib/libbonobo-activation.so.4
0x00116500  0x00141c38  Yes (*)     /lib/libgobject-2.0.so.0
0x00bb7b40  0x00c35098  Yes (*)     /lib/libglib-2.0.so.0
0x009bcaa0  0x00ae0e44  Yes (*)     /lib/libc.so.6
0x00b9e880  0x00ba26b8  Yes (*)     /lib/librt.so.1
0x00980830  0x0099832f  Yes (*)     /lib/ld-linux.so.2
0x00811d90  0x008397c8  Yes (*)     /usr/lib/libORBit-2.so.0
0x00168370  0x001f98d8  Yes (*)     /usr/lib/libX11.so.6
0x00d15c30  0x00d16d88  Yes (*)     /lib/libgmodule-2.0.so.0
0x03ef9fd0  0x03f193e8  Yes (*)     /usr/lib/libgnomecanvas-2.so.0
0x04bc8350  0x04bda418  Yes (*)     /usr/lib/libart_lgpl_2.so.2
0x04c59ed0  0x04c64bb8  Yes (*)     /usr/lib/libgnome-2.so.0
0x00d1bf40  0x00d1d6b8  Yes (*)     /lib/libgthread-2.0.so.0
0x006c9b00  0x007af1b8  Yes (*)     /usr/lib/libxml2.so.2
0x005111b0  0x0051e2e8  Yes (*)     /usr/lib/libatk-1.0.so.0
0x0046b2b0  0x00486a38  Yes (*)     /usr/lib/libpangoft2-1.0.so.0
0x00495610  0x0049aae8  Yes (*)     /usr/lib/libpangocairo-1.0.so.0
0x002963c0  0x002ff7a8  Yes (*)     /usr/lib/libfreetype.so.6
0x00350f60  0x0036ccf8  Yes (*)     /usr/lib/libfontconfig.so.1
0x00921380  0x00925d28  Yes (*)     /usr/lib/libSM.so.6
0x0095f530  0x0096f208  Yes (*)     /usr/lib/libICE.so.6
0x048af350  0x048b4b38  Yes (*)     /lib/libpopt.so.0
0x003cde70  0x003d03a8  Yes (*)     /usr/lib/libXfixes.so.3
0x00b3b470  0x00b55968  Yes (*)     /lib/libm.so.6
0x0032b720  0x00335f48  Yes (*)     /usr/lib/libXext.so.6
0x003d52c0  0x003db178  Yes (*)     /usr/lib/libXrender.so.1
0x00dfa780  0x00dfb258  Yes (*)     /usr/lib/libXinerama.so.1
0x0033d780  0x00347628  Yes (*)     /usr/lib/libXi.so.6
0x003e0150  0x003e4c58  Yes (*)     /usr/lib/libXrandr.so.2
0x003eae40  0x003f0418  Yes (*)     /usr/lib/libXcursor.so.1
0x040b5890  0x040b6488  Yes (*)     /usr/lib/libXcomposite.so.1
0x006647c0  0x00665248  Yes (*)     /usr/lib/libXdamage.so.1
0x00b64a60  0x00b65a88  Yes (*)     /lib/libdl.so.2
0x00cfc650  0x00d0af78  Yes (*)     /lib/libresolv.so.2
0x00c97370  0x00ca8fc8  Yes (*)     /lib/libselinux.so.1
0x004a16f0  0x004bd6d8  Yes (*)     /usr/lib/libpng12.so.0
0x005d4b40  0x0062cad8  Yes (*)     /usr/lib/libpixman-1.so.0
0x00b89620  0x00b94888  Yes (*)     /lib/libz.so.1
0x04abfc50  0x04ac0968  Yes (*)     /usr/lib/libORBitCosNaming-2.so.0
0x00d28e80  0x00d37608  Yes (*)     /usr/lib/libxcb.so.1
0x005aff70  0x005b3ac8  Yes (*)     /usr/lib/libgailutil.so.18
0x04b072a0  0x04b43d08  Yes (*)     /usr/lib/libgnomevfs-2.so.0
0x004c8040  0x004e0ef8  Yes (*)     /lib/libexpat.so.1
0x00859fc0  0x0085bbe8  Yes (*)     /lib/libuuid.so.1
0x00df5a00  0x00df67f8  Yes (*)     /usr/lib/libXau.so.6
0x0465be60  0x046934a8  Yes (*)     /usr/lib/libssl.so.10
0x042e6e80  0x043ca038  Yes (*)     /usr/lib/libcrypto.so.10
0x04af1940  0x04af2ac8  Yes (*)     /usr/lib/libavahi-glib.so.1
0x048eb550  0x048f17a8  Yes (*)     /usr/lib/libavahi-common.so.3
0x049008e0  0x04909f58  Yes (*)     /usr/lib/libavahi-client.so.3
0x00978a20  0x009792c8  Yes (*)     /lib/libutil.so.1
0x008e6540  0x00913d18  Yes (*)     /lib/libgssapi_krb5.so.2
0x0444a160  0x044c4438  Yes (*)     /lib/libkrb5.so.3
0x0089ce30  0x0089db68  Yes (*)     /lib/libcom_err.so.2
0x008b5c10  0x008d1198  Yes (*)     /lib/libk5crypto.so.3
0x008a3d10  0x008a8e98  Yes (*)     /lib/libkrb5support.so.0
0x008ae950  0x008af1d8  Yes (*)     /lib/libkeyutils.so.1
0x0028c350  0x0028cc88  Yes (*)     /usr/lib/gconv/ISO8859-1.so
0x004efa00  0x004f7998  Yes (*)     /lib/libnss_files.so.2
0x0092aad0  0x0094ec18  Yes (*)     /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so
0x00460070  0x004609d8  Yes (*)     /usr/lib/gtk-2.0/modules/libpk-gtk-module.so
0x004fd680  0x004ff778  Yes (*)     /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so
0x005024f0  0x005039d8  Yes (*)     /usr/lib/libcanberra-gtk.so.0
0x0063c3c0  0x006462f8  Yes (*)     /usr/lib/libcanberra.so.0
0x04d55720  0x04d5a858  Yes (*)     /usr/lib/libvorbisfile.so.3
0x04d29a10  0x04d3fd48  Yes (*)     /usr/lib/libvorbis.so.0
0x04bba310  0x04bbcb88  Yes (*)     /usr/lib/libogg.so.0
0x04d16610  0x04d1f858  Yes (*)     /usr/lib/libtdb.so.1
0x005b7a30  0x005bc468  Yes (*)     /usr/lib/libltdl.so.7
0x0064cb00  0x00659208  Yes (*)     /usr/lib/gio/modules/libgioremote-volume-monitor.so
0x00692990  0x0069d4d8  Yes (*)     /usr/lib/libgvfscommon.so.0
0x00e2b380  0x00e45f98  Yes (*)     /usr/lib/gio/modules/libgvfsdbus.so
0x04512f40  0x0451c9a8  Yes (*)     /lib/libudev.so.0
(*): Shared library is missing debugging information.
$1 = 0x0
No symbol table is loaded.  Use the "file" command.
eax            0x0	0
ecx            0xb23	2851
edx            0x6	6
ebx            0xb23	2851
esp            0xbff1af48	0xbff1af48
ebp            0xbff1af60	0xbff1af60
esi            0x96c2020	158081056
edi            0xb31ff4	11739124
eip            0xcbf424	0xcbf424 <__kernel_vsyscall+16>
eflags         0x202	[ IF ]
cs             0x73	115
ss             0x7b	123
ds             0x7b	123
es             0x7b	123
fs             0x0	0
gs             0x33	51
Dump of assembler code for function __kernel_vsyscall:
   0x00cbf414 <+0>:	push   %ecx
   0x00cbf415 <+1>:	push   %edx
   0x00cbf416 <+2>:	push   %ebp
   0x00cbf417 <+3>:	mov    %esp,%ebp
   0x00cbf419 <+5>:	sysenter 
   0x00cbf41b <+7>:	nop
   0x00cbf41c <+8>:	nop
   0x00cbf41d <+9>:	nop
   0x00cbf41e <+10>:	nop
   0x00cbf41f <+11>:	nop
   0x00cbf420 <+12>:	nop
   0x00cbf421 <+13>:	nop
   0x00cbf422 <+14>:	jmp    0xcbf417 <__kernel_vsyscall+3>
=> 0x00cbf424 <+16>:	pop    %ebp
   0x00cbf425 <+17>:	pop    %edx
   0x00cbf426 <+18>:	pop    %ecx
   0x00cbf427 <+19>:	ret    
End of assembler dump.
Comment 2 Red Hat Case Diagnostics 2011-06-13 14:18:55 EDT
Created attachment 504516 [details]
File: backtrace
Comment 11 RHEL Product and Program Management 2012-07-10 02:16:24 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2012-07-10 19:15:48 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 28 errata-xmlrpc 2013-11-21 18:31:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1708.html

Note You need to log in before you can comment on or make changes to this bug.