Bug 713033 - [zh_TW] ibus-chewing problem
Summary: [zh_TW] ibus-chewing problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-chewing
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ding-Yi Chen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 723121 745371
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-14 02:47 UTC by Hawk
Modified: 2012-09-17 22:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-03 22:53:59 UTC
Type: ---


Attachments (Terms of Use)

Description Hawk 2011-06-14 02:47:06 UTC
Description of problem:
1) Inputted characters will be pasted around when moving between windows.
    Although it could be avoided by hitting "Enter" twice or hitting Esc
    or closing ibus, it creates new lines and bugs users.

2) Highlighted characters will be cropped and gone when moving between
    windows.

3) Switch to Chewing or type Chewing in a new window.Let say I want to type the word "  
   我", ㄨ should be shown when I hit the first key, which is "j" on the keyboard.  
   Instead, "j" is shown directly.To get rid of it, I have to delete "j" and Chewing is
   back again.Switching between Chewing and English also works.

4) After typing some keys, a candidate is usually shown and underscored. If
   Enter is pressed, the candidate is chosen and the character is inputted
   successfully. But if Enter on the "number keyboard" is pressed, it creates a
   new line and the candidate is still underscored (waiting to be chosen).

   Another user who uses "Plain Zhuyin" under Chewing tried to reproduce the
   above problem. ibus crashed with the error message below:

   ibus-Chewing 當機
    版本: ibus-chewing-1.3.9.2-1.fc14
    錯誤原因:Process /usr/libexec/ibus-engine-chewing was killed by signal 11
   (SIGSEGV)

5) Unlike most IM in ibus, hitting "shift" in Chewing won't switch
    between Chinese and English. Can it be improved? 

Version-Release number of selected component (if applicable):
- Version: ibus-chewing-1.3.9.2-1.fc14.i686


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Cheng-Chia Tseng 2011-06-17 08:26:10 UTC
I can confirm "1" and "2". Those are major bugs, and should be resolved as soon as possible for Traditional Chinese users.

Comment 2 Hawk 2011-07-11 06:50:30 UTC
As Chewing is not a default ibus IM in f15, I installed ibus-chewing by myself.

To allow Chewing work as it should, I need to uncheck the "simple Zhuyin mode"
in ibus preference. However, it doesn't let me to and an error message pops up:

   Process /use/libexec/ibus-engine-chewing was killed by signal 11 (SIGSEGV)

This problem is still there even I close and open ibus again. 

版本: ibus-chewing-1.3.9.2-3.fc15.i686

thanks.

Comment 3 Ding-Yi Chen 2011-07-19 07:02:12 UTC
(In reply to comment #2)
> As Chewing is not a default ibus IM in f15, I installed ibus-chewing by myself.

I've create a new bug: 
Bug 723121 ibus-chewing: Is not default for [zh_TW] In Fedora 15
to track this

Comment 4 Cheng-Chia Tseng 2011-08-29 12:31:03 UTC
The problem 1 is still bothers users.

This is quite critical, and should be fixed as soon as possible. It has been bothers fedora 15, and We, ibus-chewing users , hope it won't continue to bother fedora 16.


Another way to reproduce:

1. open firefox
2. use ibus-chewing to type 我 at the awesome bar (url bar) of firefox
3. click the search box next to awesome bar to make the cursor be focus in it, and then 我 is pasted to the search box. At the moment, ibus-chewing will be in "Englsih" mode.
4. use Ctl+Space to switch back to "Chinese" mode to input, and 我 is pasted again


By the way, the problem 2 and 3 does not occur with ibus-chewing 1.3.9.2 on fedora 15.

Comment 5 Cheng-Chia Tseng 2011-08-29 12:33:46 UTC
Problem 5 has been reported to ibus project on google code, the link is http://code.google.com/p/ibus/issues/detail?id=1079

Comment 6 Ding-Yi Chen 2011-09-14 06:40:52 UTC
Problem 4 has been reported in Google code as issue 1303
http://code.google.com/p/ibus/issues/detail?id=1303

Comment 7 Cheng-Chia Tseng 2011-09-30 10:12:28 UTC
Could problem 1 target to be fixed on fedora 17 realease? It is really bothering when typing...

Comment 8 Ding-Yi Chen 2011-10-14 04:11:23 UTC
Hi,

Problem 1 and 4 is fixed in ibus-chewing-1.3.10, which is in updates-testing of F-16, F-15, and F-14.  

I was not be able to reproduce 2, so pleas make comment if ibus-chewing-1.3.10 is still act in that way.

I am still investigating problem 3, as it is not that reproducible.

After problem 3 is resolved, I will implement problem 5 and make a new release.

Comment 9 Hawk 2011-10-19 06:46:44 UTC
Hi Ding-Yi Chen,

We updated to ibus-chewing-1.3.10 and tried to reproduce all the problems.

Like what you discovered, problem 1 and 4 are fixed. In addition, we found problem 3 is fixed. That means, only problem 2 and problem 5 still exist.


To be specific, I'd like to explain problem 2 again.

Situation 1:
1. input two characters "今天" in openoffice writer
2. highlight 今天
3. move cursor to another window, 今天 in openoffice window will be gone
4. then hit undo, 今天 will be back

Situation 2:
1. input two characters "今天" in openoffice writer
2. move cursor to another window
3. move cursor back to openoffice window and highlight 今天
4. move cursor to another window, 今天 in openoffice window are still there

Conclusion:
- 今天 will be gone only if they are highlighted before moving to another window.

- Note that this problem is not limited to Chinese characters. It could be English or numbers also.

Thanks again,

Comment 10 Cheng-Chia Tseng 2011-10-24 15:50:16 UTC
I use "sudo yum install --enablerepo=updates-testing ibus-chewing" to test 1.3.10 for the situation Hawk issued.

I cannot reproduce Situation 1 and Situation 2 with fedora 15. 
I use GNOME3 and GNOME Shell as default, not fallback mode.

What's your enviromnet?

Comment 11 Cheng-Chia Tseng 2011-10-24 15:56:23 UTC
OK, I reproduced this problem in GNOME3 fallback mode.

Comment 12 Cheng-Chia Tseng 2011-10-24 16:02:29 UTC
Em... I use deafault mode, and the problem is reproduceds too. Maybe I turned off ibus-chewing before I got to another window then. :P

Situation 1 and Situation 2 are comfirmed.

Comment 13 Cheng-Chia Tseng 2011-10-24 16:42:22 UTC
Another test case to show off the problem:

1. Open 3 windows, one is LibreOffice Writer, other is gedit, and the other is firefox

2. In Writer window, switch to Chewing to input "你好". Hilight "你好", and switch to firefox
3. Switch back to Writer, "你好" is gone

4. Now go to firefox, input "你好" in the search box. Hilight it and switch to Writer
5. Switch back to firefox, "你好" is still there

6. Go to gedit, input "你好". Hilight it, and switch to firefox
7. Switch back to gedit, "你好" is still there

8. Go to gedit again, input another "你好". Hilight "你好" you just input (you have two now), and switch to Writer
9. Switch back to gedit, the new "你好" you input is gone (one 你好 left)

Kind of odd.

Comment 14 Cheng-Chia Tseng 2012-03-10 07:46:08 UTC
Is there any progress on problem 2 and problem 5?

Comment 15 Ding-Yi Chen 2012-08-10 08:06:31 UTC
(In reply to comment #14)
> Is there any progress on problem 2 and problem 5?

The released ibus-chewing-1.4.0 addressed 5, and the upcoming 1.4.1 will fix 1 and 2.

Comment 16 Fedora Update System 2012-08-24 04:49:30 UTC
ibus-chewing-1.4.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-chewing-1.4.2-1.fc18

Comment 17 Fedora Update System 2012-08-24 04:49:56 UTC
ibus-chewing-1.4.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-chewing-1.4.2-1.fc17

Comment 18 Fedora Update System 2012-08-24 04:50:17 UTC
ibus-chewing-1.4.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-chewing-1.4.2-1.fc16

Comment 19 Fedora Update System 2012-08-24 21:32:34 UTC
Package ibus-chewing-1.4.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-chewing-1.4.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12633/ibus-chewing-1.4.2-1.fc18
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2012-09-03 22:53:59 UTC
ibus-chewing-1.4.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2012-09-03 22:56:46 UTC
ibus-chewing-1.4.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2012-09-17 22:42:26 UTC
ibus-chewing-1.4.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.