Bug 71305 - scrolling prints blank for every non-ascii char
Summary: scrolling prints blank for every non-ascii char
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-12 09:29 UTC by Daniel Resare
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-09-27 19:26:57 UTC


Attachments (Terms of Use)
the ugly gnome startup sound with swedish chars in title (33.35 KB, application/x-ogg)
2002-08-12 09:30 UTC, Daniel Resare
no flags Details

Description Daniel Resare 2002-08-12 09:29:27 UTC
Description of Problem:
starting with limbo xmms has stopped displaying non-ascii chars in the scrolling
text of the main window. If you right-click on the tite and select 'File info'
you get the name correctly with non-ascii chars.

Version-Release number of selected component (if applicable):
xmms-1.2.7-9

How Reproducible:
always

Steps to Reproduce:
1. download and play the attached ogg
2. watch the scrolling song title
3. watch the title in the file info dialog

Actual Results:
in the scrolling text all non-ascii chars are replaced by blank


Additional Information:
the problem is reproducible in locales sv_SE.UTF-8 and en_US

Comment 1 Daniel Resare 2002-08-12 09:30:48 UTC
Created attachment 69984 [details]
the ugly gnome startup sound with swedish chars in title

Comment 2 Bill Nottingham 2002-08-14 05:52:54 UTC
It's almost certainly interpreting the file title as unicode. What locale are
you running in?

Comment 3 Daniel Resare 2002-08-15 09:22:18 UTC
As i stated above the problem is reproducible in at least locales sv_SE.UTF-8
and en_US (which seems to default to ISO-8859-1). In the C locale (that has
charset ANSI_X3.4-1968, that is US-ASCII) no non-ascii characters gets
displayed, neither in the scrolltext or in the File info dialog, which is logical.

Comment 4 Colin Walters 2004-09-27 19:26:57 UTC
Confirmed and moved upstream here:
http://bugs.xmms.org/show_bug.cgi?id=1917


Note You need to log in before you can comment on or make changes to this bug.