Bug 713074 - Missing serial port prevent hvm guest start via libvirt
Summary: Missing serial port prevent hvm guest start via libvirt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 699611
TreeView+ depends on / blocked
 
Reported: 2011-06-14 08:08 UTC by Miroslav Rezanina
Modified: 2012-02-21 05:55 UTC (History)
6 users (show)

Fixed In Version: xen-3.0.3-133.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:55:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
xend log (17.38 KB, text/plain)
2011-12-08 08:34 UTC, Shengnan Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0160 normal SHIPPED_LIVE xen bug fix and enhancement update 2012-02-20 14:53:33 UTC

Description Miroslav Rezanina 2011-06-14 08:08:00 UTC
Description of problem:
When guest config is missing serial port specification, libvirt uses "-serial none" qemu option. However, this breaks xen qemu as it does not implement proper handling for none value of serial.

Proper handling has to be implemented.

Comment 3 Paolo Bonzini 2011-07-13 12:23:29 UTC
Is this a regression?  And perhaps we want this in 5.7.z anyway...

Comment 6 Shengnan Wang 2011-12-08 08:34:55 UTC
Created attachment 542410 [details]
xend log

Comment 8 errata-xmlrpc 2012-02-21 05:55:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0160.html


Note You need to log in before you can comment on or make changes to this bug.