Bug 71308 - SIGHUP can terminate session
SIGHUP can terminate session
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-12 05:45 EDT by Kjetil T. Homme
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 01:50:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2002-08-12 05:45:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020808

Description of problem:
after adding another X server to gdm.conf and sending SIGHUP, the existing
session is thrown out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. be logged on to :0
1. add 1=Standard vt8 to [servers] in gdm.conf
2. kill -HUP `cat /var/run/gdm.pid`
3. wait a few seconds

Actual Results:  the X server on :0 was terminated


Expected Results:  the default /etc/X11/gdm/gdm.conf says:
# (HUP will make gdm not kill existing sessions and will only restart gdm
# after all users log out)


Additional info:

gdm-2.4.0.7-1
Comment 1 Havoc Pennington 2002-08-12 15:23:25 EDT
Potentially just bogus docs, I'm not sure.
Comment 2 George Lebl 2002-08-13 10:34:48 EDT
Yeah, bogus doc.  Should be USR1.  HUP does immediate restart USR1 does safe
restart.  There are also two scripts gdm-restart and gdm-safe-restart that do
this for you.
Comment 3 Kjetil T. Homme 2002-08-13 20:21:10 EDT
okay, thanks for the info.  (I'd prefer HUP to be the safe restart, since that's
what xdm does, but...)

gdm-*restart isn't included in the RPM, but that's OK.  one of these days I'm
sure Red Hat will make the ${pref}dm run from a normal initscript, so we can
write "service gdm reload" and have it do the right thing.

a manual page would be nice, btw :-)
Comment 4 Bill Nottingham 2002-08-14 01:50:48 EDT
Can't do 'service gdm'. Other VTs aren't initialized yet, so X startup gets screwed.
Comment 5 Elliot Lee 2002-08-26 14:05:03 EDT
Bogus docs fixed, nothing else to do besides educate users :)

Note You need to log in before you can comment on or make changes to this bug.