Bug 71310 - Window list most of the time is Really slow switching applications
Window list most of the time is Really slow switching applications
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 71469
  Show dependency treegraph
 
Reported: 2002-08-12 06:03 EDT by Nathan G. Grennan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 19:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-08-12 06:03:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
The window list applet causes Slow switching of applications most of the time.
Using alt-tab is most of the time alot faster.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Open Galeon maximized
2. Open Evolution maximized
3. Click which ever one is not on top at the moment in the window list
	

Actual Results:  Most of the time takes 2-3 seconds to switch/draw

Expected Results:  Near instant switch

Additional info:

Limbo beta2
Comment 1 Havoc Pennington 2002-08-12 15:29:19 EDT
I really think this is probably your imagination, or a coincidence in when you
use one vs. the other (e.g. use alt+tab when you have recently been using the
other window). The code involved is exactly the same.
Comment 2 Nathan G. Grennan 2002-08-12 15:55:33 EDT
No, this is definitely a problem. I was just trying it and found it seems to be
related to load. Under no load it behaves just a little slower. Under load it is
noticably slower to use the window list. This may be related to another bug I
reported about an auto-hiding panel and applets not instantly refreshing their
graphics.
Comment 3 Havoc Pennington 2002-08-12 16:06:03 EDT
Well if you are heavily swapping then the tasklist approach involves swapping in
the panel, while the alt+tab doesn't. Maybe that's the issue.
Comment 4 Nathan G. Grennan 2002-08-12 16:32:55 EDT
No swap space, just 768mb of memory.
Comment 5 Havoc Pennington 2002-08-13 17:39:58 EDT
Conceivably just extra time to context switch to the panel process?

I dunno, there's no code here to optimize in the actual window list applet.
Nothing about it takes noticeable time, very little code actually has to run
in respnose to the click. Must be some kind of system issue.
Comment 6 Nathan G. Grennan 2002-08-13 18:56:39 EDT
This behavior seems unique to Sawfish 2.0. I don't see this with metacity.

This is becoming a reoccuring them.

Note You need to log in before you can comment on or make changes to this bug.