Bug 71315 - Notification, Weather, and Mixer applet redraw too slow
Notification, Weather, and Mixer applet redraw too slow
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-applets (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks: 71469
  Show dependency treegraph
 
Reported: 2002-08-12 06:26 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 19:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-08-12 06:26:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Using an auto-hide panel, hide and unhide the panel repeated after adding the
Notification, Weather, or Mixer applets to the panel. The area they are in on
the panel will grey out and take a few seconds or more to redraw.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add Notification, Weather, or Mixer applets to the panel
2. Set panel to auto-hide
3. Hide and unhide panel repeatedly
	

Actual Results:  Grey area where applet should be

Expected Results:  Near instant refresh of applet graphics

Additional info:
Comment 1 Havoc Pennington 2002-08-13 16:28:52 EDT
What sort of CPU do you have?

May just be because the limbo2 kernel has a bunch of debug goo in it.
Comment 2 Nathan G. Grennan 2002-08-13 17:24:00 EDT
Athlon XP 1700+ aka 1.47ghz, should be plenty fast.
Comment 3 Nathan G. Grennan 2002-08-13 18:59:01 EDT
This behavior seems unique to Sawfish 2.0. I don't see this with metacity.


I think this relates to some focus problem with Sawfish, though that is just a
guess. Doesn't seem to matter which focus mode.

Note You need to log in before you can comment on or make changes to this bug.