Bug 71336 - Badly distorted fonts when not using anti-aliasing
Badly distorted fonts when not using anti-aliasing
Product: Red Hat Public Beta
Classification: Retired
Component: freetype (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Depends On:
  Show dependency treegraph
Reported: 2002-08-12 09:51 EDT by Mark Round
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-12 09:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Round 2002-08-12 09:51:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a)
Gecko/20020611 MultiZilla/v1.1.15

Description of problem:
If I use anti-aliasing, fonts appear smooth - but the
moment I turn this off, things get seriously ugly and unreadable - in KDE,GNOME,
Mozilla, and OpenOffice. 

I've got a 2 screen shots at
http://www.markround.com/files/snapshot3.png and snapshot1.png so you can see
what I mean. This is using Helvetica, but even after I install the scalable
MS TTF webfonts, I still get this problem. (IE:- Using "Arial" instead of
"Helvetica") The fonts are set to their default "point" size, and they still
look distorted.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Disable anti-aliasing in any dekstop environment.
2. Restart X in the case of KDE. It's immediate under GNOME.

Actual Results:  The fonts changed form being easy to read and well-formed to
being seriously distorted and unreadable.

Expected Results:  The fonts should have remained readable and well-scaled.
Under RH7.3, without Anti-aliasing, fonts remain well defined and legible.

Additional info:

I've tried installing some nice TTF fonts, changing the order of the
fonts listed in /etc/X11/fs/config, altering my DPI settings - and
still no joy. What's interesting is that I got the same problem under another
distro (Mandrake 8.2) - but not on RH 7.3.

Reproduced on two different computers. One laptop with Trident Cyberblade and
Toshiba LCD (Satellite Pro 4600), and one desktop PC (nVidia GeForce MX ,
Samsung monitor)
Comment 1 Owen Taylor 2002-08-12 11:28:56 EDT
Good non-antialiased display of freetype fonts requires the use
of TrueType bytecode hints. See:


(see also the without_bytecode_interpreter define in the freetype

Note You need to log in before you can comment on or make changes to this bug.