This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 71344 - rpm hangs instead of being locked
rpm hangs instead of being locked
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-12 11:19 EDT by Simon Matter
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 11:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Matter 2002-08-12 11:19:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.2.19-6.2.16 i686)

Description of problem:
It is now several times that I couldn't do anything rpm related after issuing
some commands. Seems the database is not unlocked how it should.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. rpm -q imap
2. rpm -e imap
3.
	

Actual Results:  Nothing happens. No prompt. Only kill -9 helps.

Expected Results:  imap should have been deleted.

Additional info:

When I experienced this the first time, I did a
rm -f /var/lib/rpm/__db.00*
and everything is was again. It happened three times today while building RPMs.
Looks like there is a locking problem somewhere.
Comment 1 Jeff Johnson 2002-08-12 12:50:33 EDT
Yup, fixed in rpm-4.1 from Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.