Bug 713483 - libusb-config missing from libusb-devel
Summary: libusb-config missing from libusb-devel
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libusb
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jan Vcelak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-15 14:21 UTC by Alex Cobb
Modified: 2013-03-04 01:29 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-06-25 19:58:31 UTC


Attachments (Terms of Use)

Description Alex Cobb 2011-06-15 14:21:40 UTC
Description of problem:
libusb-config is missing from libusb-devel. Perhaps this was a deliberate choice? As far as I understand, all the same relevant information can be obtained with pkg-config, but some other packages use libusb-config at the configuration stage, e.g., gpsbabel (see Additional info, below).

Version-Release number of selected component (if applicable):
libusb-0.1.3-7.fc15.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. enter libusb-config at the command prompt
  
Actual results:
bash: libusb-config: command not found

Expected results:
libusb-config can be used to obtain linking information and flags for libusb

Additional info:
# rpm -ql libusb-devel | grep config
/usr/lib64/pkgconfig/libusb.pc

As far as I can tell, libusb-config is not available in any package available in standard repositories for Fedora 15:
yum provides */libusb-config
...
No Matches found

I found this issue when trying to use gpsbabel with a USB device.  Under Fedora 14 this worked, but under Fedora 15 I get:
USB support is not available in this build.
(gpsbabel-1.4.2-5.fc15.src.rpm)
When configuring gpsbabel 1.4.2 from source, detection of libusb fails (although ./configure succeeds) because of the absence of libusb-config:
checking for libusb... checking for libusb-config... false

Comment 1 Felix Möller 2011-06-20 20:30:54 UTC
I just wanted to report the same issue. This is a regression.

Comment 2 Felix Möller 2011-06-20 20:50:02 UTC
This has been introduced with:
http://pkgs.fedoraproject.org/gitweb/?p=libusb.git;a=commitdiff;h=a82f37afdf2bca8db2312e1612a63a7edd0d4176

adding libusb-config back to the package allows me to rebuild the gpsbabel rpm with usb support.

Comment 3 Felix Möller 2011-06-20 22:12:16 UTC
I just wrote a mail to Hans Ulrich Niedermann who seems to be maintaining gpsbabel, which is rendered useless to me by this issue.

Comment 4 Jan Vcelak 2011-06-21 08:46:54 UTC
Sorry, I've missed that. libusb-config is back in libusb-0.1.3-8.fc15

Comment 5 Fedora Update System 2011-06-21 08:47:21 UTC
libusb-0.1.3-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libusb-0.1.3-8.fc15

Comment 6 Fedora Update System 2011-06-21 23:54:22 UTC
Package libusb-0.1.3-8.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libusb-0.1.3-8.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libusb-0.1.3-8.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-06-22 08:17:16 UTC
libusb-0.1.3-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libusb-0.1.3-9.fc15

Comment 8 Felix Möller 2011-06-22 08:19:05 UTC
@Jan could you rebuilt gpsbable which was broken by this?

Comment 9 Jan Vcelak 2011-06-22 09:06:25 UTC
@Felix, I don't have permissions to do that. I created separate bug 715220 on gpsbabel, you were added to CC. I suppose the maintainers will react soon.

Comment 10 Alex Cobb 2011-06-24 02:54:06 UTC
libusb-config works again after updating with libusb-0.1.3-9.fc15.  Fixed for me. Thanks!

Comment 11 Fedora Update System 2011-06-25 19:58:26 UTC
libusb-0.1.3-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.