This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 713512 - [rtl8187] Fedora 15 wireless was poor at install and now has NO wireless after yum upgrade
[rtl8187] Fedora 15 wireless was poor at install and now has NO wireless afte...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-15 11:50 EDT by Shaun Andrew
Modified: 2012-06-20 13:27 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 13:27:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shaun Andrew 2011-06-15 11:50:29 EDT
Description of problem:  Installed Fedora 15 x86_64 from ISO DVD.  The wireless interface was poor, so I hacked the /etc/sysconfig/network_scripts/ifcfg-wlan0 file and got the DNS working.  Performed a yum upgrade via the wireless interface that I hacked to get around the crappy wireless configuration utility.  The yum upgrade downloaded and installed smoothly.  Rebooted system and now there is NO wireless, cannot see wireless networks, and the NeatGear wireless USB adapter, WG111v2, (driver rtl8187) is DEAD.  lsmod shows rtl8187 is loaded.  Fedora 15 YUM UPGRADE SENT WIRELESS FROM BAD TO WORSE.  (I have rebooted system in Fedora 14 and I am writing this bug report from same DEAD wireless adapter in Fedora 15.)


Version-Release number of selected component (if applicable):
Suspect NetworkManager as the culprit.
Fedora wireless has ALWAYS been poor on all platforms that I have ever installed it on.  Fedora wireless configurations ALWAYS needs hacking to get them to work.  (I am writing this bug report from a hacked Fedora 14 wireless configuration.)

How reproducible:
ALWAYS

Steps to Reproduce:
1. Install Fedora 15, wireless DNS is poor unless configuration is hacked to fix it.
2. yum upgrade, NO more wireless at all.  Wireless is DEAD after yum upgrade.
3.
  
Actual results:
NO wireless after yum upgrade.  System cannot see any wireless networks.

Expected results:
wireless DNS issues resolved after yum upgrade and wireless is stable

Additional info:
Fedora wireless is holding Fedora back.  If the Fedora developers could get the wireless stable and configurable, then you would see an explosion in Fedora users!
Comment 1 Jirka Klimes 2011-06-17 08:54:51 EDT
You should provide some data otherwise your report is not of much use.
Could you give us:
1. /etc/sysconfig/network_scripts/ifcfg-wlan0 and your changes
2. $ nm-tool
3. $ rfkill list
4. /var/log/messages
5. any errors in dmesg regarding WiFi card?
Comment 2 duy duy 2011-08-19 21:10:54 EDT
Hello , my problem same as .
And I find the main problem here : 
[   18.182176] udev[406]: renamed network interface eth0 to em1
[   18.413625] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[   18.648752] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[   18.837138] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.0
[   18.837143] ath9k_htc 1-1:1.0: ath9k_htc: Please upgrade to FW version 1.3
[   18.837764] Failed to initialize the device
[   18.846904] ath9k_htc: probe of 1-1:1.0 failed with error -22
[   18.846945] usbcore: registered new interface driver ath9k_htc

I'm using :
Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Comment 3 duy duy 2011-08-19 21:41:39 EDT
Now , my wireless works again .
Here is my steps : 
 - 1 . Go to http://wireless.kernel.org/download/htc_fw/1.3/ , download htc_9271.fw and copy it to /lib/firmware/
 - 2. Unplug usb wirless and plug agian .
 
Thanks Jirka Klimes about dmesg . It is very useful .
Comment 4 Shaun Andrew 2011-09-27 11:14:20 EDT
I finally made time to "hack" my Fedora 15 network configuration so that wireless-networking is stable.  This is basically the same "hack" configuration that I have had to use with EVERY Fedora release since I started using wifi.  (I started using wifi with Fedora 12.)

Basically the "hacked" wireless configuration does the following:
1) statically sets 11Mbps transfers
2) statically sets Primary and Secondary DNS under dhcp

I have tried directly editing /etc/sysconfig/network-scripts to accomplish the same changes that I see were made with system-config-network; however, I appear to be missing something, since my direct edits do not get the wireless network functioning.

Configuring with system-config-network:

1) acquire system-config-network-1.6.2-2.fc15.noarch.rpm
2) install system-config-network rpm
3) run system-config-network or select via KDE
Applications->Administration->Network Configuration
4) select the Devices Tab
4) select the wireless device
6) select Edit
7) select the General Tab
8) check Controlled by NetworkManager
9) check Activate device when computer starts
10) select Automatically obtain IP address settings with: dhcp
11) STATICALLY set both primary and secondary DNS IP addresses, i.e., 8.8.8.8 and 8.8.4.4
12) Select the Wireless Settings Tab
13) select Mode: Auto
14) select Specified and enter SSID of the wireless network 
15) STATICALLY set Transit rate: 11M
16) enter the wireless networks security key in the "key" field
17) select OK
18) select the DNS Tab and STATICALLY set same primary and secondary DNS IP addresses
19) select the File Menu
20) select Save, then Yes or Ok to the following dialog boxes
21) reboot
22) from the KDE system tray configure the wireless network as normal, but STATICALLY set the same primary and secondary DNS IP addresses as before.  (Note: "Transmit rate:" is NOT an option for wireless networks configured from the the system tray.  Once everything is configured using the system tray then Activate the wireless network from the system tray.  Notice that the Transmit Rate is now STATICALLY 11Mbps.

If you were to go back and run system-config-network again, select Device Tab, select Edit, select Wireless Settings Tab, you would now see that the Mode: is Managed (not Auto), and Transmit rate: is Auto (not 11M).)  system-config-network does the necessary low-level changes that make Fedora wireless possible.
Comment 5 Dan Williams 2011-09-27 14:56:54 EDT
If you ever have to manually set the data rate to a specific data rate, that is an indication that the kernel driver (or the rate control module) for that specific hardware has a bug.  In this case, it would indicate that the rtl8187 driver is not working correctly with your access point.  rtl8187 is a pretty old driver that I don't think has recieved a lot of attention lately.  But in the end, rate control issues are kernel bugs.
Comment 6 saneeha 2011-10-03 13:22:02 EDT
hey I cannot save IP address on wired link using GNOME settings, on fedora 15 (64bit). Pl help. things do not even work for wireless. The only option I am getting is to acquire ip address through DHCP
Comment 7 saneeha 2011-10-03 13:22:41 EDT
hey I cannot save IP address on wired link using GNOME settings, on fedora 15 (64bit). Pl help. things do not even work for wireless. The only option I am getting is to acquire ip address through DHCP
Comment 8 saneeha 2011-10-03 13:26:13 EDT
hey I cannot save IP address on wired link using GNOME settings, on fedora 15 (64bit). Pl help. things do not even work for wireless. The only option I am getting is to acquire ip address through DHCP
Comment 9 Jirka Klimes 2011-10-04 02:21:43 EDT
(In reply to comment #6)
> hey I cannot save IP address on wired link using GNOME settings, on fedora 15
> (64bit). Pl help. things do not even work for wireless. The only option I am
> getting is to acquire ip address through DHCP

saneeha, this bug deals with rtl8187 driver issues.
Please, open a new bug for your problem and describe in more detail what your problem is, what you want to achieve and which tools/programs you use (nm-connection-editor, GnomeShell network indicator, ...). Attaching /var/log/messages to the new bug would help, too.
Comment 10 laurelai 2011-10-25 01:11:48 EDT
I have the same problem on 32 bit fedora 15 witht the same type of RTL8187 Wireless Adapter, after yum update it wont even detect my device (lsusb and rfkill list show nothing) but before update the wireless works very poorly, the internet will connect for 30 seconds to 5 minutes before gradually slowing down to a halt, disconnecting and reconnecting the device fixes it until it happens again, yum upgrading to the latest took 4 hours and i did this based on advice from irc support, they insisting this would fix the problem. Google searching has shown that the linux drivers for this chipset are just not very good, is there any way to have better drivers written?
Comment 11 John B Davis Jr 2011-12-09 13:45:27 EST
I also have a weak signal using the rtl8187 module since Fedora 11.  Now with Fedora 16 with the same poor performance, I find CDlinux (slackware 2009) and Tiny Core Linux v4.1 (current) have just as good rtl8187 modules as Windows.  

PCLinux 2009 has poor rtl8187 module performance as does TinyMe Linux 2008 (PCLinux 2008 derived), but this is to be expected as they are all Mandriva derived OSes and this comes back to the poor Red Hat modules.

A friend tells me SuSe 12.1 has good rtl8187 performance
Comment 12 Josh Boyer 2012-06-06 10:29:04 EDT
Is this still a problem with the 2.6.43/3.3 kernel updates in F15/F16?
Comment 13 John B Davis Jr 2012-06-20 12:42:31 EDT
This is no longer a problem in F16 using kernel-PAE 3.3.7-1.  I made a comparison of signal strength using the rtl8187 module and ndiswrapper (using Microsoft XP driver as given by the Installing Ndiswrapper Kernel Modules - Fedora Unity Project).  Signal strength is the same in both methods.
Comment 14 Josh Boyer 2012-06-20 13:27:53 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.