Bug 71352 - RFE: Please include LDAP support in Postfix
RFE: Please include LDAP support in Postfix
Status: CLOSED DUPLICATE of bug 64816
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: John Dennis
Depends On:
  Show dependency treegraph
Reported: 2002-08-12 12:28 EDT by sean
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description sean 2002-08-12 12:28:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Postfix is not built with LDAP support by default.  I think it should be -
especially if Sendmail is build with LDAP support (it is).  If the user doesn't
want to use it then it is no more/less in the way then the SASL dependency.  In
fact, the current SRPM in 7.3.93 won't even build with LDAP enabled even though
there is a build toggle for it.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Obtain/Install Limbo 7.3.93
2. rpm -q --requires postfix | grep libldap
3. rpm -q --requires sendmail | grep libldap
3. See that sendmail is built with LDAP but Postfix isn't.  Be confused.
4. Try to build postfix with LDAP - see error.	

Actual Results:  
# rpm -q --requires postfix | grep libldap
# rpm -q --requires sendmail | grep libldap

# rpmbuild -bb postfix.spec 
(watch lots of build stuff)
./../include -DLINUX2 -o error error.o ../../lib/libmaster.a
../../lib/libglobal.a ../../lib/libutil.a -L/usr/lib -lldap -llber -lpcre -lsasl
-lssl -lcrypto -ldb -lnsl -lresolv
../../lib/libutil.a(dict_ldap.o): In function `dict_ldap_get_values':
dict_ldap.o(.text+0x5d1): undefined reference to `ldap_url_search_st'
collect2: ld returned 1 exit status
make: *** [error] Error 1
make: *** [update] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.95491 (%build)

Expected Results:  
# rpm -q --requires postfix | grep libldap
# rpm -q --requires sendmail | grep libldap

and a package that will at least let you rebuild it with LDAP support.

Additional info:

It is very nice to have LDAP support for all the various options in Postfix and
if a site depends on LDAP support in Sendmail then the lack of it in Postfix
will keep them from considering it as an alternative.
Comment 1 Simon Matter 2002-08-13 10:25:49 EDT
Me too, I need it. I didn't try to compile with LDAP but my postfix servers
usually use LDAP so it's a must.
Comment 2 Petri T. Koistinen 2002-09-02 15:35:19 EDT
I would like to see LDAP support too.
Comment 3 Chris Ricker 2002-12-19 02:09:00 EST

*** This bug has been marked as a duplicate of 64816 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.