Bug 713534 - Disabling of TouchPad using gpointing-device-settings does not stick through a reboot
Summary: Disabling of TouchPad using gpointing-device-settings does not stick through ...
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 15
Hardware: x86_64
OS: Unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2011-06-15 17:42 UTC by David Batson
Modified: 2013-01-12 23:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-08-07 15:46:27 UTC
Type: ---

Attachments (Terms of Use)

Description David Batson 2011-06-15 17:42:35 UTC
Description of problem:
Disabling of Touchpad in Applications > Pointing Devices does not stick
through a reboot.

Version-Release number of selected component (if applicable):

How reproducible:
Disable TouchPad in Applications > Pointing Devices and TouchPad is disabled.  Reboot and TouchPad is no longer disabled although the box is still checked for it to be disabled in Pointing Devices.  Have to enable it in Pointing Devices, then disable it in Pointing Devices for it to again be disabled.

Steps to Reproduce:
1. Disable TouchPad in Pointing Devices
2. Reboot
3. TouchPad no longer disabled although it is still checked as being disabled in Pointing Devices.
Actual results:
Disabling of TouchPad does not stick through a reboot.

Expected results:
Once TouchPad is disabled in Pointing Devices, I expect it to remain disabled until I choose otherwise.

Additional info:
This is an old bug that is still not resolved.

Comment 1 David Batson 2011-06-15 20:27:18 UTC
I should have stated this is on a ThinkPad X220 with both the TrackPoint and TouchPad onboard (UltraNav).

[david@localhost ~]$ dmesg | grep IBM
[    8.463267] IBM TrackPoint firmware: 0x0e, buttons: 3/3
[    8.715844] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio2/input/input6

[david@localhost ~]$ dmesg | grep Synaptics
[    1.824376] Synaptics Touchpad, model: 1, fw: 8.0, id: 0x1e2b1, caps: 0xd001a3/0x940300/0x120c00
[    1.824383] serio: Synaptics pass-through port at isa0060/serio1/input0
[    1.876853] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input4

[david@localhost ~]$

Comment 2 David Batson 2011-07-14 00:57:18 UTC
I did not think that the scrolling feature was working with my TrackPoint, but I discovered that it does if I choose the correct button (#2).  However this feature likewise does not stick through a reboot.

Everytime I reboot I have to open gpointing-device-settings at least 6 times!

First to uncheck "Disable touchpad", Second to recheck "Disable touchpad", Third to change wheel button from 2 to 4, Fourth to change wheel button from 4 to 2, Fifth to uncheck "Use wheel emulation", Sixth to recheck "Use wheel emulation".

No such problems in Mageia 1 KDE.

Comment 3 Alexander Volovics 2011-10-01 10:16:10 UTC

I have a Thinkpad T520 also with UltrNav and the same touchpad
and trackpoint as you (I think).

cat /proc/bus/input/devices shows:
- SynPS/2 Synaptics Touchpad
- TPPS/2 IBM Trackpoint
and dmesg shows the same as you mention above.

I have added myself to bug 710053 with regard to the
gpointing-device-settings package failure to save settings.

My question to you is did the touchpad work 'out of the box'
(after installing F15) or did you have to add some xorg config.

With the T520 the trackpoint works (minus 'wheel' function) but
the touchpad does not work at all.

Comment 4 David Batson 2011-10-03 00:11:12 UTC
My touchpad worked out of the box in F15, but since I don't use it, I am not sure if all the available functions were there.  I know that it did move the mouse pointer.

I did not initially create an xorg.conf, but did later to use libva for Intel graphics acceleration.  I have a copy of my xorg.conf in the following post:

Here is my current workaround for this bug.  Looks like no one is interested in fixing it.

Comment 5 Pavel Šimerda (pavlix) 2012-03-20 23:12:06 UTC
This bug is still present in Fedora 17:


Comment 6 Fedora End Of Life 2012-08-07 15:46:30 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:

Comment 7 Pavel Šimerda (pavlix) 2012-08-09 12:31:55 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=713534#c5, this bug report is still valid.

Comment 8 rstp 2013-01-12 23:03:30 UTC
Still present, related to: https://bugzilla.redhat.com/show_bug.cgi?id=710053

Note You need to log in before you can comment on or make changes to this bug.