Bug 713550 - Add missing 'install on RHEL 6' into RHN Satellite Installation guide
Add missing 'install on RHEL 6' into RHN Satellite Installation guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
Depends On: 713527
Blocks: sat54-docs
  Show dependency treegraph
 
Reported: 2011-06-15 14:40 EDT by Clifford Perry
Modified: 2013-10-23 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 713527
Environment:
Last Closed: 2011-06-23 17:28:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2011-06-15 14:40:47 EDT
Description of problem:
When reviewing the 5.4.1 RHN Satellite Installation guide on internal staging environment I noticed we were missing mention of RHEL 6 as a supported option for installation. 

The process for installing has not changed, compared to RHEL 5. 

We need to update the Satellite document to mention this. 

Version-Release number of selected component (if applicable):

Red Hat Network Satellite 5.4.1
 Installation Guide 
  Edition 2
   Revision 2-1	Fri May 27 2011

How reproducible:
Always
  
Actual results:
Inclusion of RHEL 6 along side of any mention of RHEL 5 for installation. Also, we should not be mentioning old installation on RHEL 4 AS - which use to be a supported option. So this is 'add RHEL 6' and remove any old 'RHEL 4' lingering in docs.

Expected results:

1) 
FROM:
Log into the RHN website (rhn.redhat.com) and download the distribution ISOs for Red Hat Enterprise Linux AS 4 or Red Hat Enterprise Linux 5 and RHN Satellite. 

TO:
Log into the RHN website (rhn.redhat.com) and download the distribution ISOs for Red Hat Enterprise Linux 5 or Red Hat Enterprise Linux 6 and RHN Satellite. 

2) 
FROM:
Register a representative machine for each distribution type, or channel (such as Red Hat Enterprise Linux 4 or 5), to the Satellite. 

TO:
Register a representative machine for each distribution type, or channel (such as Red Hat Enterprise Linux 5 or 6), to the Satellite. 
Additional info:

3) 
FROM:
Base operating system — RHN Satellite is supported with Red Hat Enterprise Linux 5

TO:
Base operating system — RHN Satellite is supported with Red Hat Enterprise Linux 5 and Red Hat Enterprise Linux 6.

4)
FROM:
Satellite can be installed on Red Hat Enterprise Linux 5 in any virtualized environment ...

TO:
Satellite can be installed on Red Hat Enterprise Linux 5 or Red Hat Enterprise Linux 6 in any virtualized environment ...

5)
FROM:
RHN Satellite supports SELinux targeted policy in enforcing or permissive mode on Red Hat Enterprise Linux 5. 

TO:
RHN Satellite supports SELinux targeted policy in enforcing or permissive mode on Red Hat Enterprise Linux 5 and Red Hat Enterprise Linux 6. 

6)
FROM:
When installing Red Hat Enterprise Linux 5 or later from CD or ISO image, 

TO:
When installing Red Hat Enterprise Linux 5 or Red Hat Enterprise Linux 6 from CD or ISO image, 

7) This is a big one. NOTE I drop s390 from table since neither OS version support it, otherwise we should add PPC, etc. 

FROM:
RHN Satellite supports several hardware architectures. The following table illustrates the architecture support for RHN Satellite on Red Hat Enterprise Linux 5. Red Hat Enterprise Linux 5.

Table 2.1. RHN Satellite on Red Hat Enterprise Linux Architecture Support

RHEL Version 	x86 	x86_64 	s390 	s390x
RHEL 5 	yes 	yes 	no 	yes

TO:
RHN Satellite supports several hardware architectures. The following table illustrates the architecture support for RHN Satellite on Red Hat Enterprise Linux 5 and Red Hat Enterprise Linux 6. 

Table 2.1. RHN Satellite on Red Hat Enterprise Linux Architecture Support

RHEL Version 	x86 	x86_64 	s390x
RHEL 5 	yes 	yes 	yes
RHEL 6  no      yes     yes


8)
FROM:
Subscribing to these channels and updating your Satellite (such as by running yum on Red Hat Enterprise Linux 5 or 5 or up2date on earlier versions of Red Hat Enterprise Linux) 

TO:
Subscribing to these channels and updating your Satellite (such as by running yum update) 

9)
FROM:
rpm --import /media/RHEL_5/RPM-GPG-KEY-redhat-release

TO:
For RHEL 5:
 rpm --import /media/RHEL_5/RPM-GPG-KEY-redhat-release

For RHEL 6:
 rpm --import /media/RHEL_6/RPM-GPG-KEY-redhat-release

10)
FROM:
Complete a minimal installation of Red Hat Enterprise Linux 4 or 5

TO:
Complete a minimal installation of Red Hat Enterprise Linux 5 or 6

11)
FROM:
If you encounter any issues with SELinux messages (such as AVC denial messages) on Red Hat Enterprise Linux 5 while installing RHN Satellite

TO:
If you encounter any issues with SELinux messages (such as AVC denial messages) while installing RHN Satellite

12)
FROM:
Subscribing to these channels and updating your Satellite (such as by running yum on Red Hat Enterprise Linux 5 (or up2date on earlier Red Hat Enterprise Linux versions), 

TO:
Subscribing to these channels and updating your Satellite (such as by running yum), 

13)
FROM:
the user should be able to run yum update (or up2date -u on versions of Red Hat Enterprise Linux earlier than version 5) on the RHN Satellite

TO:
the user should be able to run yum update on the RHN Satellite

14)
FROM:
For instance, a new Satellite will require both a Management or Provisioning entitlement for Red Hat Enterprise Linux AS and an RHN Satellite entitlement. 

TO:
For instance, a new Satellite will require both a Management and Provisioning entitlement for Red Hat Enterprise Linux and an RHN Satellite entitlement. 

15)
FROM:
If you do wish to run MySQL probes, subscribe the Satellite to the Red Hat Enterprise Linux AS channel and install the mysql-server package either through the RHN website or by yum (or up2date for earlier versions of Red Hat Enterprise Linux). 

TO:
If you do wish to run MySQL probes, subscribe the Satellite to the Red Hat Enterprise Linux channel and install the mysql-server package either through the RHN website or by yum. 

16)
FROM:
Install RHN Satellite with Embedded Database (and a base install of Red Hat Enterprise Linux AS) on a separate machine, skipping the SSL Certificate generation step. 

TO:
Install RHN Satellite with Embedded Database (and a base install of Red Hat Enterprise Linux) on a separate machine, skipping the SSL Certificate generation step. 

17)
FROM:
Install RHN Satellite with Stand-Alone Database (and a base install of Red Hat Enterprise Linux AS) on a separate machine

TO:
Install RHN Satellite with Stand-Alone Database (and a base install of Red Hat Enterprise Linux) on a separate machine



We note that installation of Satellite on RHEL 6 Server is supported within the 5.4.1 Release Notes.
Comment 1 Lana Brindley 2011-06-21 21:19:31 EDT
Fixed in Revision 2-3.

LKB
Comment 2 Lana Brindley 2011-06-22 00:32:41 EDT
Requested respin in RT#114048

LKB

Note You need to log in before you can comment on or make changes to this bug.