Bug 713590 - AntTweakBar-1.14-1 not built with $RPM_OPT_FLAGS
AntTweakBar-1.14-1 not built with $RPM_OPT_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: AntTweakBar (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sean Middleditch
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2011-06-15 16:46 EDT by Ville Skyttä
Modified: 2011-06-16 04:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-15 17:59:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2011-06-15 16:46:30 EDT
AntTweakBar-1.14-1 is not built with $RPM_OPT_FLAGS:
http://kojipkgs.fedoraproject.org/packages/AntTweakBar/1.14/1.fc16/data/logs/x86_64/build.log

1.13-6 did not have this problem:
http://kojipkgs.fedoraproject.org/packages/AntTweakBar/1.13/6.fc15/data/logs/x86_64/build.log

grepping through the 1.14 source tarball I find nothing related to FEDORA_CXXFLAGS.  Setting CXXCFG instead of it might fix it (untested).
Comment 1 Sean Middleditch 2011-06-15 17:59:22 EDT
Huh.  I didn't change the build setup at all, so it's strange that it would have worked right in the old version.  I pushed a 1.14-2 that fixes this issue.
Comment 2 Ville Skyttä 2011-06-16 01:31:47 EDT
(In reply to comment #1)
> Huh.  I didn't change the build setup at all,

The AntTweakBar-makefile.patch which was in 1.13-6 had stuff related to FEDORA_CXXFLAGS.
Comment 3 Sean Middleditch 2011-06-16 04:55:41 EDT
Ah.  Well now I just feel silly, since I wrote that patch.  :)  Setting the proper variable for the build system in the spec file makes more sense anyway though, at least.

Note You need to log in before you can comment on or make changes to this bug.