Bug 713598 - python-async-debuginfo is empty
python-async-debuginfo is empty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-async (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2011-06-15 16:52 EDT by Ville Skyttä
Modified: 2013-01-10 01:37 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-20 09:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2011-06-15 16:52:24 EDT
python-async-debuginfo is empty.  Should the package be actually noarch (yep, it installs to /usr/lib64 on x86_64, but should it)?

If not, the debuginfo package should be explicitly disabled if there's nothing to extract debuginfo from.
Comment 1 Jesse Keating 2011-06-16 15:49:50 EDT
It builds a binary python module that is arch dependent.  What's the right way to prevent a debuginfo package from being automatically generated?
Comment 2 Ville Skyttä 2011-06-17 13:08:09 EDT
(In reply to comment #1)
> It builds a binary python module that is arch dependent.

Ah, I see that's the intention from the build logs, but it actually fails to do that:

http://kojipkgs.fedoraproject.org/packages/python-async/0.6.1/1.fc16/data/logs/x86_64/build.log

gcc -pthread -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC -I/usr/include/python2.7 -c mod/zlibmodule.c -o build/temp.linux-x86_64-2.7/mod/zlibmodule.o
mod/zlibmodule.c:8:18: fatal error: zlib.h: No such file or directory
compilation terminated.
Ignored failure when building extensions, pure python modules will be used instead

Adding "BuildRequires: zlib-devel" fixes that, and results in proper debuginfo as well.

> What's the right way to prevent a debuginfo package from being automatically
> generated?

Following the links in the DebugInfo bug this one blocks:
http://fedoraproject.org/wiki/Packaging:Debuginfo
...but there's no need to do anything about the debuginfo package after the zlib-devel BR fix.
Comment 3 Jesse Keating 2011-06-17 13:49:22 EDT
Ooooh!  Good catch!  I didn't see this in my local builds due to having zlib-devel installed.  I'll fix this right away.

Note You need to log in before you can comment on or make changes to this bug.