Bug 7136 - exmh (sedit) sometimes puts .sig in the middle of MIME messages
exmh (sedit) sometimes puts .sig in the middle of MIME messages
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: exmh (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-19 05:59 EST by David Woodhouse
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-22 13:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 1999-11-19 05:59:51 EST
When composing MIME messages with exmh's built-in editor, it sometimes
puts the .signature in the middle of the message, rather than at the end as
it should.

This example is not so bad - because the .sig ended up in the middle of a
text section - but I've previously seen it turn up in the middle of a 4Mb
base64 attachment.

This example was from exmh-2.1.1, but I've seen it happen (albeit very
rarely) from exmh-2.0.0 onwards. It's not easy to reproduce it, though.

Offending message follows:

X-Mailer: exmh version 2.1.1 (devel)
In-Reply-To: <01BF31DA.E8729C40.rhys.amarilli@insnet.net>
References: <01BF31DA.E8729C40.rhys.amarilli@insnet.net>
To: Rhys <rhys.amarilli@insnet.net>
Cc: "'samantha.hopkins@insnet.net'" <samantha.hopkins@insnet.net>
Subject: Re: Your return phone call...
Mime-Version: 1.0
Content-Type: multipart/mixed ;
	boundary="==_Exmh_15677662780"
Date: Fri, 19 Nov 1999 09:59:10 +0000
From: David Woodhouse <dwmw2@devel2.axiom.internal>

This is a multipart MIME message.

--==_Exmh_15677662780
Content-Type: text/plain; charset=us-ascii


rhys.amarilli@insnet.net said:
> The support team are telling me that they still need the headers from

--
dwmw2
> you.

> I know that you have already done this and that they bear no relevance
> at all but can you resend them please.

Rhys, if the person you were talking to wants to see the headers after
seeing
the explanation of why the mail loop happens, then they're obviously
clueless,
so they're not someone who you want to be touching your mail system.

Please could you put me in touch with someone who's actually qualified for
the
job they're doing instead. I appreciate that front line support people have
to
deal with so many stupid queries that it's not worth employing people who
really know what they're doing, but surely you have _someone_ there with a
clue?

The fix to two of your problems is simple:
	1. Make sure your autoresponder doesn't respond to error messages.
	2. Make sure your autoresponder's responses have error message status
		so that nothing else will autoreply to them.

This is a universally-accepted solution which prevents such mail loops, and
frankly I'm amazed that whoever set this up didn't know enough to do it
right
in the first place.

The fix to the third involves a little more thought - but read
	http://www.linx.net/events/talk_mansfield.html
and	http://www.linx.net/noncore/bcp/ube-bcp.html

... and consider my suggestion that you start using ORBS on your own mail
relays, at least for mail outgoing from your customers - to protect your
offending customers from causing inconvenience to your innocent customers
by
landing you in the blacklists yourself.

Here are the headers again anyway.

--==_Exmh_15677662780
Content-Type: message/rfc822 ; name="33"
Content-Description: 33
Content-Disposition: attachment; filename="33"

From postmaster@cygnus.uk.insnet.net Thu Nov 18 13:23:03 1999
Received: from firewall.axiom.internal ([10.0.1.1] helo=gate.mvhi.com)
	by server.axiom.internal with esmtp (Exim 3.03 #1)
	id 11oRWg-0007Wi-00
	for David.Woodhouse@mvhi.com; Thu, 18 Nov 1999 13:23:02 +0000
Received: from mail.edex.net.uk ([194.177.174.244]
helo=orion.uk.insnet.net)
	by gate.mvhi.com with esmtp (Exim 1.90 #1)
	for David.Woodhouse@mvhi.com
	id 11oRWe-0004ca-00; Thu, 18 Nov 1999 13:23:00 +0000
Received: from cygnus.uk.insnet.net (cygnus.uk.insnet.net [194.177.160.40])
	by orion.uk.insnet.net (8.9.3/8.9.3) with ESMTP id NAA25518
	for <David.Woodhouse@mvhi.com>; Thu, 18 Nov 1999 13:23:00 GMT
Received: from cygnus.uk.insnet.net (localhost [127.0.0.1])
	by cygnus.uk.insnet.net (8.8.8+Sun/8.8.8) with SMTP id NAA05914
	for <David.Woodhouse@mvhi.com>; Thu, 18 Nov 1999 13:22:59 GMT
Date: Thu, 18 Nov 1999 13:22:59 GMT
Message-Id: <199911181322.NAA05914@cygnus.uk.insnet.net>
Subject: Mail delayed: Re: [Ticket ID #1999111727] Re:Mail loops caused by
    your autoresponder and listing in ORBS.
To: David.Woodhouse@mvhi.com
References: <E11oRWT-0007WS-00@server.axiom.internal>
In-Reply-To: <E11oRWT-0007WS-00@server.axiom.internal> from David
    Woodhouse on Thu, 18 Nov 1999 13:22:49 +0000
From: followups@insnet.net
X-Mailer: Perl5 Mail::Internet v1.32
Sender: <postmaster@cygnus.uk.insnet.net>
X-RBL-Warning: Open relay - see
http://www.orbs.org/verify.cgi?address=194.177.174.244

David Woodhouse <David.Woodhouse@mvhi.com> writes:
>This is an automatically generated message. Please read it carefully
>and then forward it to your email system administrator for action.
>
>Your mail entitled: "Re: [Ticket ID #1999111727] Re:Mail loops caused by
your
>    autoresponder and listing in ORBS."
>is suspected of being spam. It has been delivered, but rather than
>going into the recipient's inbox, it has been stored in a
>"Suspected Spam" mail folder which may not be read for some time,
>if ever. There is no need to resend the message unless you have fixed
>your server and would like your message to receive immediate attention.
>
>This probably happened because your mail server is misconfigured,
>and is listed on an Internet-wide blacklist.
>
>You should be aware that many computers on the Internet will simply
>refuse to accept your mail at all.
>
>The exact reason why your mail has been flagged in this way is:
>	Open relay - see http://www.orbs.org/verify.cgi?address=194.177.174.244
>
>For more information, see http://www.orbs.org/blocked.cgi or send
>a mail to postmaster@mvhi.com


******************************************************
This is an automatic reply to your mail message.
Your mail regarding 'Mail delayed: Re: [Ticket ID #1999111727] Re:Mail
loops caused by
    your autoresponder and listing in ORBS.' has been received, a followup
has been added to the master ticket
For more information or correspondence on this issue please
Telephone the INS NOC on: +44(0)1203 723 030.
Alternatively, add a followup to your master ticket by
emailing noc-tickets@insnet.net with your master
ticket in the subject line, i.e. in this format [#1999010101]
******************************************************

---------------------------------------------------------------------------
Ticket ID  ------:
Issue -----------: Mail delayed: Re: [Ticket ID #1999111727] Re:Mail loops
caused by
    your autoresponder and listing in ORBS.
Opened by -------: David Woodhouse <David.Woodhouse@mvhi.com>
Date opened -----: Thu Nov 18 13:22:58 1999

---------------------------------------------------------------------------
Issue:

This is an automatically generated message. Please read it carefully
and then forward it to your email system administrator for action.

Your mail entitled: "Re: [Ticket ID #1999111727] Re:Mail loops caused by
your
    autoresponder and listing in ORBS."
is suspected of being spam. It has been delivered, but rather than
going into the recipient's inbox, it has been stored in a
"Suspected Spam" mail folder which may not be read for some time,
if ever. There is no need to resend the message unless you have fixed
your server and would like your message to receive immediate attention.

This probably happened because your mail server is misconfigured,
and is listed on an Internet-wide blacklist.

You should be aware that many computers on the Internet will simply
refuse to accept your mail at all.

The exact reason why your mail has been flagged in this way is:
	Open relay - see http://www.orbs.org/verify.cgi?address=194.177.174.244

For more information, see http://www.orbs.org/blocked.cgi or send
a mail to postmaster@mvhi.com

---------------------------------------------------------------------------
           Further information on this Ticket is available on:
		INS +44 (0)181 239 5005
---------------------------------------------------------------------------
This message was generated automatically by FLASH at http://www.insnet.net


--==_Exmh_15677662780--
Comment 1 Michael K. Johnson 1999-11-22 13:06:59 EST
I've only ever seen this when the cursor was inadvertently moved to the
point of insertion.

I'd suggest that you file this bug with the "Help...->Submit bug report"
option within exmh, as the exmh developers has a far better chance of
fixing it than we do.  Many folks at Red Hat use exmh extensively and
this is the first I've heard of this bug, so I expect that this is
specific to your configuration; in any case, I'm unable to reproduce
this.

Note You need to log in before you can comment on or make changes to this bug.