Bug 713636 - run stress testing on guest cause host shutdown
run stress testing on guest cause host shutdown
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Karen Noel
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-06-16 00:41 EDT by Suqin Huang
Modified: 2013-01-09 18:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 07:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages info (122.60 KB, text/plain)
2011-07-11 07:25 EDT, Suqin Huang
no flags Details

  None (edit)
Description Suqin Huang 2011-06-16 00:41:39 EDT
Description of problem:
host shutdown while run stress testing on guest

Version-Release number of selected component (if applicable):
kvm-83-237.el5

How reproducible:
2/2

Steps to Reproduce:
1. cmd
qemu-kvm -drive file=/images/RHEL-Server-5.6-64-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -net nic,vlan=0,model=virtio,macaddr='9a:bd:56:49:18:c0' -net tap,vlan=0,script='/usr/autotest/client/tests/kvm/scripts/qemu-ifup-switch',downscript='no' -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -boot c  -usbdevice tablet -no-kvm-pit-reinjection

2. run stress on guest
#stress --cpu 4 --io 4 --vm 4 --vm-bytes 1020487680 --hdd 4 --hdd-bytes 1048576 --timeout 60
3.
  
Actual results:
host shutdown

Expected results:


Additional info:

1. host
kernel: 2.6.18-266.el5

cpuinfo:
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 67
model name	: Dual-Core AMD Opteron(tm) Processor 1216
stepping	: 3
cpu MHz		: 2400.000
cache size	: 1024 KB

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
bogomips	: 4822.46
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

2. guest
rhel5.64
Comment 1 Suqin Huang 2011-06-16 00:42:29 EDT
will try to get core file and serial info
Comment 2 Suqin Huang 2011-06-20 04:41:41 EDT
no core file, and only can get serial info before os shutdown, host shutdown like Power is turn off

kvm: 3553: cpu0 unhandled wrmsr: 0x0 data 0
kvm: 3553: cpu1 unhandled wrmsr: 0x0 data 0
kvm: 3553: cpu0 unimplemented perfctr wrmsr: 0xc0010004 data 0x0
kvm: 3553: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x130076
kvm: 3553: cpu0 unimplemented perfctr wrmsr: 0xc0010004 data 0xffffffffffe4682d
kvm: 3553: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x530076
kvm: 3553: cpu1 unimplemented perfctr wrmsr: 0xc0010004 data 0x0
kvm: 3553: cpu1 unimplemented perfctr wrmsr: 0xc0010000 data 0x130076
kvm: 3553: cpu1 unimplemented perfctr wrmsr: 0xc0010004 data 0xffffffffffe4682d
kvm: 3553: cpu1 unimplemented perfctr wrmsr: 0xc0010000 data 0x530076
kvm: 3553: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x0
kvm: 6744: cpu0 unimplemented perfctr wrmsr: 0xc0010004 data 0x0
kvm: 6744: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x130076
kvm: 6744: cpu0 unimplemented perfctr wrmsr: 0xc0010004 data 0xffffffffffe467e8
kvm: 6744: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x530076
kvm: 6744: cpu1 unimplemented perfctr wrmsr: 0xc0010004 data 0x0
kvm: 6744: cpu1 unimplemented perfctr wrmsr: 0xc0010000 data 0x130076
kvm: 6744: cpu1 unimplemented perfctr wrmsr: 0xc0010004 data 0xffffffffffe467e8
kvm: 6744: cpu1 unimplemented perfctr wrmsr: 0xc0010000 data 0x530076
kvm: 6744: cpu0 unimplemented perfctr wrmsr: 0xc0010000 data 0x0
Comment 3 Dor Laor 2011-07-10 10:05:06 EDT
What's /var/log/messages on the host say?
Can you hook it into regular serial so we'll see the whole complete messages?
Comment 4 Suqin Huang 2011-07-11 07:25:17 EDT
Created attachment 512187 [details]
messages info

1. this issue still exist when update BIOS to latest version 1.4.4
2. trying to run stress test on host to check if if crash (will update result tmr)
Comment 5 Suqin Huang 2011-07-12 03:33:39 EDT
host didn't crash while run stress testing in host directly. repeat 10 times


#stress --cpu 4 --io 4 --vm 4 --vm-bytes 1020487680 --hdd 4 --hdd-bytes 1048576
--timeout 60
Comment 6 Avi Kivity 2011-08-11 05:02:45 EDT
Potential duplicate of Bug 681126 - both AMD without NPT.
Comment 7 Avi Kivity 2011-08-11 05:03:38 EDT
Does the same test fail on RHEL 6?
Comment 8 Suqin Huang 2011-09-01 22:01:04 EDT
repeat around 100 times, can not reproduce it any more, will con to  test it.

Note You need to log in before you can comment on or make changes to this bug.