Bug 713678 - Not all febootstrap messages are redirected to log callbacks
Not all febootstrap messages are redirected to log callbacks
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-16 04:18 EDT by Marek Goldmann
Modified: 2012-10-19 05:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 05:28:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marek Goldmann 2011-06-16 04:18:37 EDT
Description of problem:

Some messages aren't redirected to log callback, but instead they are print to stdout. This is not really a bug, but a minor annoyance.

For example:

supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00003ms] inputs[0] = /usr/lib64/guestfs/supermin.d
checking modpath /lib/modules/2.6.38.6-27.fc15.x86_64 is a directory
picked vmlinuz-2.6.38.6-27.fc15.x86_64 because modpath /lib/modules/2.6.38.6-27.fc15.x86_64 exists
checking modpath /lib/modules/2.6.38.7-30.fc15.x86_64 is a directory
picked vmlinuz-2.6.38.7-30.fc15.x86_64 because modpath /lib/modules/2.6.38.7-30.fc15.x86_64 exists
supermin helper [00006ms] finished creating kernel
supermin helper [00007ms] visiting /usr/lib64/guestfs/supermin.d
supermin helper [00007ms] visiting /usr/lib64/guestfs/supermin.d/base.img
supermin helper [00007ms] visiting /usr/lib64/guestfs/supermin.d/daemon.img
supermin helper [00007ms] visiting /usr/lib64/guestfs/supermin.d/hostfiles
supermin helper [00054ms] visiting /usr/lib64/guestfs/supermin.d/init.img
supermin helper [00178ms] finished creating appliance
Comment 1 Richard W.M. Jones 2011-06-16 04:35:49 EDT
This happens because we run febootstrap-supermin-helper
as an external process without fully capturing its stdout and
stderr and redirecting those through the event system, eg
in the following two places:

http://git.annexia.org/?p=libguestfs.git;a=blob;f=src/appliance.c;h=56838825855027ef4ff575f81a0f943f36f330fa;hb=HEAD#l198

http://git.annexia.org/?p=libguestfs.git;a=blob;f=src/appliance.c;h=56838825855027ef4ff575f81a0f943f36f330fa;hb=HEAD#l598
Comment 2 Richard W.M. Jones 2012-10-19 05:28:35 EDT
Fixed upstream (libguestfs >= 1.19.53) by the
following commits:

2e90f4312928f332f8997b52be3fe54f20920242
8d4f3f85f2bdf38a2868ea785cf66efa65af25f3

Note You need to log in before you can comment on or make changes to this bug.