Bug 7138 - Command timeouts don't works
Command timeouts don't works
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dip (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-19 08:04 EST by Vsevolod Volkov
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-22 13:13:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SIGALRM patch (196 bytes, patch)
1999-11-19 08:06 EST, Vsevolod Volkov
no flags Details | Diff

  None (edit)
Description Vsevolod Volkov 1999-11-19 08:04:43 EST
Command timeouts don't works. For example:

# dip -t
DIP: Dialup IP Protocol Driver version 3.3.7o-uri (8 Feb 96)
Written by Fred N. van Kempen, MicroWalt Corporation.

DIP> port modem
DIP> wait TEST 1

This command is not finished after 1 second, because SIGALRM
does not interrupt read() function by default. Solution is to
use siginterrupt:

--- dip-3.3.7o/main.c.alrm      Mon Nov 15 22:05:59
1999
+++ dip-3.3.7o/main.c           Mon Nov 15 22:06:08
1999
@@ -398,2 +398,3
@@
   (void) signal(SIGQUIT,
catch);
+  (void) siginterrupt(SIGALRM,
1);
Comment 1 Vsevolod Volkov 1999-11-19 08:06:59 EST
Created attachment 6 [details]
SIGALRM patch
Comment 2 Michael K. Johnson 1999-11-22 13:13:59 EST
Thanks.  I've applied the patch and dip-3.3.7o-16 will be in the
next RawHide.

Note You need to log in before you can comment on or make changes to this bug.