Bug 713875 - GPF in libsane-qcam.so.1.0.22
GPF in libsane-qcam.so.1.0.22
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
x86_64 Linux
low Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ABRTF17
  Show dependency treegraph
 
Reported: 2011-06-16 12:23 EDT by Jerry James
Modified: 2012-05-17 08:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-17 08:42:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2011-06-16 12:23:41 EDT
Description of problem:
I see this in the logs on my Rawhide machine for each login to a Gnome3 desktop over the last few days:

Jun 16 08:52:46 jerry-rawhide64 kernel: [   72.818691] colord[1515] general protection ip:7f362cc3c437 sp:7ffff16f9080 error:0 in libsane-qcam.so.1.0.22[7f362cc36000+b000]
Jun 16 08:52:47 jerry-rawhide64 abrt[1606]: saved core dump of pid 1515 (/usr/libexec/colord) to /var/spool/abrt/ccpp-2011-06-16-08:52:46-1515.new/coredump (24502272 bytes)
Jun 16 08:52:47 jerry-rawhide64 abrtd: Directory 'ccpp-2011-06-16-08:52:46-1515' creation detected
Jun 16 08:52:47 jerry-rawhide64 abrtd: Corrupted or bad dump /var/spool/abrt/ccpp-2011-06-16-08:52:46-1515 (res:2), deleting

Version-Release number of selected component (if applicable):
sane-backends-libs-1.0.22-3.fc16.x86_64
colord-0.1.9-1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Login to a Gnome3 desktop from GDM
2.
3.
  
Actual results:
The above message appears in the logs.

Expected results:
No GPF, or at least a good crash dump.  Bug in abrt?

Additional info:
Comment 1 Nils Philippsen 2011-09-16 07:19:22 EDT
Changing component to abrt temporarily -- I need a backtrace to debug that.
Comment 2 Jiri Moskovcak 2011-09-30 02:37:20 EDT
is colord run under user who is logging into the session or it's run under some system account (like gdm?) if the second case, then you need to run ABRT as user who was running the application to see the actual crash - if you run it as root, you should see all crashes.
Comment 3 Jerry James 2011-09-30 17:42:48 EDT
It's been long enough that my Rawhide machine has changed a lot.  I don't see these messages about colord in the logs anymore.  In any case, colord is run as root.  But I don't think there's any possibility of figuring this out now, since there's no way to reproduce the problem.
Comment 4 Jiri Moskovcak 2011-11-30 10:45:48 EST
Does this still happen? I guess it was caused by unsigned packages in F16 while it was rawhide.
Comment 5 Jerry James 2011-11-30 10:54:07 EST
No, as I said in comment 3, I cannot reproduce this behavior any more.
Comment 6 Fedora Admin XMLRPC Client 2011-12-19 12:41:17 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-12-19 12:44:42 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Jiri Moskovcak 2012-05-17 08:42:06 EDT
Seems like this one is fixed. Please re-open this ticket if you hit the problem again.

Note You need to log in before you can comment on or make changes to this bug.