Bug 714156 - Log output from netfs status action is missing
Summary: Log output from netfs status action is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents
Version: 6.3
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: rc
: 6.4
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-17 13:30 UTC by Martin Juricek
Modified: 2013-02-21 07:51 UTC (History)
6 users (show)

Fixed In Version: resource-agents-3.9.2-14.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:51:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0288 0 normal SHIPPED_LIVE resource-agents bug fix and enhancement update 2013-02-20 20:36:39 UTC

Description Martin Juricek 2011-06-17 13:30:25 UTC
Description of problem:

The "status" action in netfs resource doesn't write any output to log file.
So there is no information if the status check of the nfs mount was successful or not.
Problem might be when communication with nfs server is cut-off, the service doesn't know about it.


Steps to Reproduce:
1. setup cluster service with netfs resource (set log_level="7")
2. start the service
3. watch the log messages
 
  
Actual results:
No output from netfs resource status action

Expected results:
Some output from netfs resource status action

Additional info:

For testing reasons, there is a service with netfs and ip resources. Both resources have "status" action with time interval set to 1m, but there is only ip resource activity in the log.

<rm log_facility="local6" log_level="7">
    <failoverdomains/>
    <resources>
        <netfs name="nfs1" mountpoint="/mnt/test1" host="a3" export="/tmp/nfs1" fstype="nfs" force_unmount="1">
	    <action name="status" interval="1m"/>
	</netfs>
	<ip address="10.15.89.178">
	    <action name="status" interval="1m"/>
	</ip>
    </resources>
    <service autostart="0" name="nfsservice" recovery="relocate">
        <netfs ref="nfs1"/>
        <ip ref="10.15.89.178"/>
    </service>
</rm>    


Jun 17 04:34:26 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 0 
Jun 17 04:34:26 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:34:26 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:34:26 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:35:16 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 10 
Jun 17 04:35:16 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:35:16 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:35:16 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:35:16 a1 clurgmgrd: [19855]: <debug> Local ping to 10.15.89.178 succeeded 
Jun 17 04:35:26 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 0 
Jun 17 04:35:26 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:35:26 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:35:26 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:36:16 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 10 
Jun 17 04:36:16 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:36:16 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:36:16 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:36:16 a1 clurgmgrd: [19855]: <debug> Local ping to 10.15.89.178 succeeded 
Jun 17 04:36:26 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 0 
Jun 17 04:36:26 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:36:26 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:36:26 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:37:16 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 10 
Jun 17 04:37:16 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:37:16 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:37:16 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:37:16 a1 clurgmgrd: [19855]: <debug> Local ping to 10.15.89.178 succeeded 
Jun 17 04:37:26 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 0 
Jun 17 04:37:26 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:37:26 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:37:26 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:38:16 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 10 
Jun 17 04:38:16 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:38:16 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:38:16 a1 clurgmgrd: [19855]: <debug> Link detected on eth0 
Jun 17 04:38:16 a1 clurgmgrd: [19855]: <debug> Local ping to 10.15.89.178 succeeded 
Jun 17 04:38:26 a1 clurgmgrd: [19855]: <debug> Checking 10.15.89.178, Level 0 
Jun 17 04:38:26 a1 clurgmgrd: [19855]: <debug> 10.15.89.178 present on eth0 
Jun 17 04:38:26 a1 clurgmgrd: [19855]: <debug> Link for eth0: Detected 
Jun 17 04:38:26 a1 clurgmgrd: [19855]: <debug> Link detected on eth0

Comment 8 errata-xmlrpc 2013-02-21 07:51:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0288.html


Note You need to log in before you can comment on or make changes to this bug.