Bug 714165 - yet another cdrom_release oops
yet another cdrom_release oops
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:0aee220050b6ab0e7777c473335...
:
: 714164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 10:23 EDT by Paul Stauffer
Modified: 2011-08-17 22:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.40.3-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 21:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Stauffer 2011-06-17 10:23:45 EDT
abrt version: 2.0.1
architecture:   x86_64
cmdline:        ro root=/dev/mapper/luks-6c64c191-9226-4de6-803e-9b690f3c321b rd_LUKS_UUID=luks-6c64c191-9226-4de6-803e-9b690f3c321b rd_LUKS_UUID=luks-d2dd612a-9ae9-455a-b272-c2c9f2c34e1b rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us
comment:        Just saw this in abrtd; don't know when or under what circumstances it happened.
component:      kernel
kernel:         2.6.38.6-26.rc1.fc15.x86_64
kernel_tainted: 128
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         [134245.166764] BUG: unable to handle kernel paging request at ffff8800607ccdf8
reported_to:    kerneloops: URL=http://submit.kerneloops.org/submitoops.php
time:           Fri Jun 17 09:15:22 2011

backtrace:
:[134245.166764] BUG: unable to handle kernel paging request at ffff8800607ccdf8
:[134245.166923] IP: [<ffff8800607ccdf8>] 0xffff8800607ccdf8
:[134245.167006] PGD 1a04063 PUD 1fffb067 PMD 80000000606001e3 
:[134245.167006] Oops: 0011 [#1] SMP 
:[134245.167006] last sysfs file: /sys/power/state
:[134245.167006] CPU 1 
:[134245.167006] Modules linked in: tcp_lp joydev nfs lockd fscache nfs_acl auth_rpcgss fuse ebtable_nat ebtables stp llc sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf ip6_tables arc4 snd_hda_codec_conexant iwlagn snd_hda_intel snd_hda_codec snd_hwdep snd_seq iwlcore snd_seq_device mac80211 snd_pcm microcode cfg80211 btusb bluetooth e1000e iTCO_wdt thinkpad_acpi i2c_i801 iTCO_vendor_support snd_timer snd_page_alloc rfkill snd wmi soundcore virtio_net kvm_intel kvm btrfs zlib_deflate libcrc32c xts gf128mul dm_crypt i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[134245.167006] 
:[134245.167006] Pid: 13829, comm: cdrom_id Not tainted 2.6.38.6-26.rc1.fc15.x86_64 #1 LENOVO 7469CTO/7469CTO
:[134245.167006] RIP: 0010:[<ffff8800607ccdf8>]  [<ffff8800607ccdf8>] 0xffff8800607ccdf8
:[134245.167006] RSP: 0018:ffff88000a081a70  EFLAGS: 00010282
:[134245.167006] RAX: 0000000000000010 RBX: ffff8800607ccde0 RCX: 0000000000000001
:[134245.167006] RDX: 0000000000000000 RSI: ffff8800607ccdf8 RDI: 0000000000011200
:[134245.167006] RBP: ffff88000a081ae8 R08: 0000000000000000 R09: ffff8800607cca80
:[134245.167006] R10: ffff8800bad233d0 R11: 0000000000000246 R12: 0000000000011210
:[134245.167006] R13: ffff88000a081aa8 R14: 0000000000000000 R15: ffff88008c3dc560
:[134245.167006] FS:  00007fa777bb0720(0000) GS:ffff8800bce80000(0000) knlGS:0000000000000000
:[134245.167006] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:[134245.167006] CR2: ffff8800607ccdf8 CR3: 000000010f853000 CR4: 00000000000406e0
:[134245.167006] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:[134245.167006] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:[134245.167006] Process cdrom_id (pid: 13829, threadinfo ffff88000a080000, task ffff88008c3dc560)
:[134245.167006] Stack:
:[134245.167006]  ffffffff810da28e ffff88000a081ac8 0000001081049aa0 ffff8800bce13840
:[134245.167006]  0000000100000003 ffff8800bce13840 0000000000000046 ffff88000a081ab8
:[134245.167006]  ffffffff8147588c ffff88000a081ac8 ffff88012f4e8da0 0000000000000000
:[134245.167006] Call Trace:
:[134245.167006]  [<ffffffff810da28e>] ? mempool_alloc+0x68/0x116
:[134245.167006]  [<ffffffff8147588c>] ? _raw_spin_unlock_irqrestore+0x17/0x19
:[134245.167006]  [<ffffffff81215e16>] get_request+0x180/0x262
:[134245.167006]  [<ffffffff81216891>] get_request_wait+0x35/0x193
:[134245.167006]  [<ffffffff81040dee>] ? __wake_up_common+0x4d/0x83
:[134245.167006]  [<ffffffff8147588c>] ? _raw_spin_unlock_irqrestore+0x17/0x19
:[134245.167006]  [<ffffffff81216a2e>] blk_get_request+0x3f/0x6e
:[134245.167006]  [<ffffffff812fc965>] scsi_execute+0x41/0x146
:[134245.167006]  [<ffffffff812fcb06>] scsi_execute_req+0x9c/0xce
:[134245.167006]  [<ffffffff812f8ba0>] ioctl_internal_command.constprop.1+0x6b/0x163
:[134245.167006]  [<ffffffff812f8cf1>] scsi_set_medium_removal+0x59/0x94
:[134245.167006]  [<ffffffff8130b41d>] sr_lock_door+0x20/0x22
:[134245.167006]  [<ffffffff8132c634>] cdrom_release+0x195/0x205
:[134245.167006]  [<ffffffff8104127e>] ? should_resched+0xe/0x2d
:[134245.167006]  [<ffffffff814742d0>] ? _cond_resched+0xe/0x22
:[134245.167006]  [<ffffffff8130a3b1>] sr_block_release+0x30/0x4d
:[134245.167006]  [<ffffffff81149c0e>] __blkdev_put+0xc6/0x179
:[134245.167006]  [<ffffffff81149dc5>] blkdev_put+0x104/0x10c
:[134245.167006]  [<ffffffff81149df2>] blkdev_close+0x25/0x27
:[134245.167006]  [<ffffffff81122b15>] fput+0x121/0x1bb
:[134245.167006]  [<ffffffff8112007f>] filp_close+0x66/0x70
:[134245.167006]  [<ffffffff81120126>] sys_close+0x9d/0xda
:[134245.167006]  [<ffffffff81009bc2>] system_call_fastpath+0x16/0x1b
:[134245.167006] Code: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 60 cf 7c 60 00 88 ff ff 00 02 20 00 00 00 ad de 00 00 01 00 00 00 00 00 <f8> cd 7c 60 00 88 ff ff f8 cd 7c 60 00 88 ff ff d5 4d 07 81 ff 
:[134245.167006] RIP  [<ffff8800607ccdf8>] 0xffff8800607ccdf8
:[134245.167006]  RSP <ffff88000a081a70>
:[134245.167006] CR2: ffff8800607ccdf8

event_log:
:2011-06-17-10:23:39> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-06-17-10:23:41  Kernel oops report was uploaded
Comment 1 Dave Jones 2011-07-11 18:01:42 EDT
This is very likely another variant of Bug 708718
Please try the update mentioned there.
Comment 2 Dave Jones 2011-07-11 18:06:00 EDT
*** Bug 714164 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2011-07-29 11:54:48 EDT
This bug should be fixed with 2.6.40-3 and higher (available in updates-testing. Please try that kernel, and leave feedback.

Thanks.
Comment 4 Fedora Update System 2011-07-29 12:01:26 EDT
kernel-2.6.40-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40-3.fc15
Comment 5 Fedora Update System 2011-07-29 16:40:28 EDT
kernel-2.6.40-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40-4.fc15
Comment 6 Fedora Update System 2011-07-30 23:33:38 EDT
Package kernel-2.6.40-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40-4.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.40-4.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-08-01 21:58:16 EDT
kernel-2.6.40-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2011-08-16 08:48:30 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 9 Fedora Update System 2011-08-17 22:31:21 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.