Bug 714169 - libvirt spec should require radvd
libvirt spec should require radvd
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
All Linux
medium Severity medium
: ---
: ---
Assigned To: Laine Stump
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 10:31 EDT by Jeff Bastian
Modified: 2012-06-06 20:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 20:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2011-06-17 10:31:21 EDT
Description of problem:
libvirt.spec should have "Requires: radvd" since radvd is necessary for IPv6 autoconf.  This has already been fixed in rawhide:
http://pkgs.fedoraproject.org/gitweb/?p=libvirt.git;a=commit;h=ed6c49f874e2692f6b3d534d772dfe8707dac68f

Version-Release number of selected component (if applicable):
libvirt-0.8.8-4.fc15.x86_64

How reproducible:
every time

Steps to Reproduce:
1. yum install libvirt
2. rpm -q radvd
  
Actual results:
radvd is not installed

Expected results:
radvd is installed as a dependency

Additional info:
Define an IPv6 range for a virtual network and radvd should be running for it:

$ cat ipv6test.xml
<network>
  <name>ipv6test</name>
  <uuid>5ef6bd20-6adf-ee4a-744a-23ba5ba4a538</uuid>
  <forward mode='nat'/>
  <bridge name='ipv6test' stp='on' delay='0' />
  <ip address='192.168.199.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.199.64' end='192.168.199.128' />
    </dhcp>
  </ip>
  <ip family='ipv6' address='2001:d00:dad:1::1' prefix='64'>
  </ip>
</network>

$ sudo virsh net-define ipv6test.xml

$ sudo virsh net-start ipv6test

$ pgrep -lf radvd
16980 radvd --debug 1 --config /var/lib/libvirt/radvd/ipv6test-radvd.conf --pidfile /var/run/libvirt/network/ipv6test-radvd.pid-bin
Comment 1 Fedora Admin XMLRPC Client 2011-09-22 13:53:46 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2011-09-22 13:57:45 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-11-30 15:04:43 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 15:05:01 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 15:08:51 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 15:09:03 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Laine Stump 2011-12-01 13:51:18 EST
This was fixed in the following commit (which ended up in libvirt-0.9.0 upstream)

commit 206fc979b1656722b254e683d89b3e9fc4480c63
Author: Eric Blake <eblake@redhat.com>
Date:   Wed Mar 23 10:30:49 2011 -0600

    rpm: add missing dependencies
    
    Among others, the missing radvd dependency showed up as:
    
    error: Failed to start network ipv6net
    error: Cannot find radvd - Possibly the package isn't installed: No such file
    or directory
    
    even when radvd was installed, because the RADVD preprocessor
    symbol was missing at configure time.
    
    * libvirt.spec.in (with_network): Add BuildRequires for radvd,
    iptables, and ip6tables.
    (BuildRequires): Add libxslt and augeas for docs and test.
    (with_libvirtd): Add module-init-tools for modprobe.
    (with_nwfilter): Add BuildRequires for ebtables.
    (with_esx): Fix esx build on RHEL 5, thanks to curl-devel rename.
Comment 8 Cole Robinson 2012-06-06 20:53:57 EDT
Not that important for this point in F15 cycle, and fix is already in F16+. Closing as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.