This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 714230 - similar to bugs 462095/676708, ifdown-eth does not support VLAN tags on descriptively-named interfaces
similar to bugs 462095/676708, ifdown-eth does not support VLAN tags on descr...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
: ZStream
Depends On:
Blocks: 854852
  Show dependency treegraph
 
Reported: 2011-06-17 12:27 EDT by james.greene
Modified: 2014-09-08 08:33 EDT (History)
11 users (show)

See Also:
Fixed In Version: initscripts-9.03.32-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Too strict naming policy for VLAN names Consequence: if-down didn't work for descriptively-named interfaces Fix: Name format check removed Result: Now it works as expected
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:25:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test patch (610 bytes, patch)
2011-06-17 12:51 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description james.greene 2011-06-17 12:27:27 EDT
Description of problem:

/etc/sysconfig/network-scripts/ifdown-eth needs the same type of patch as ifup received as per bugs 462095/676708:

143c143
<     if echo ${DEVICE} | LANG=C egrep -v '(:)' | LANG=C egrep -q '(eth|bond)[0-9]*\.[0-9][0-9]?[0-9]?[0-9]?' \
---
>     if echo ${DEVICE} | LANG=C egrep -v '(:)' | LANG=C egrep -q '.+\.[0-9][0-9]?[0-9]?[0-9]?' \

The new initscripts rpm only patches ifup.

This supports functional/descriptive naming of interfaces (including biosdevname-style) where VLANs are used.

Without this patch, the vconfig rem is never called to remove the VLAN tag, leaving orphan VLAN config entries.


Version-Release number of selected component (if applicable):

All Redhat 5 and 6 with VLAN config support in ifup/ifdown-eth


How reproducible:

Every time.


Steps to Reproduce:
1. Confirm no VLAN tag set by cat /proc/net/vlan/config
2. Configure a VLAN interface on a descriptively named device, eg, "data.555" in ifcfg-data.555 and run "ifup data.555". (Requires current initscripts or manual edit to ifup.)
3. "ifdown data.555"   (no errors reported)
4. See that VLAN 555 still present in /proc/net/vlan/config
  
Actual results:

VLAN 555 tag still in /proc/net/vlan/config, data.555@data device still exists.


Expected results:

VLAN 555 tag should be removed from /proc/net/vlan/config, and data.555@data devices does not exist.


Additional info:

Minor but easily fixed.
Comment 2 Bill Nottingham 2011-06-17 12:51:57 EDT
Created attachment 505314 [details]
test patch

Just from reading the code, this seems far simpler than worrying about the device name.

Will require some testing on all the earlier releases. Does this work for you?
Comment 3 Suzanne Yeghiayan 2011-10-06 14:50:25 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.
               
Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Lukáš Nykrýn 2012-06-08 04:56:31 EDT
Bill's patch looks correct to me, but can you please also try it?
Comment 5 Meni Yakove 2012-09-03 03:28:35 EDT
Test Bill patch on RHEL 6.3 and VLAN was deleted (em1.200).
Comment 8 Václav Pavlín 2012-09-06 03:04:32 EDT
Patch committed to upstream git -> http://git.fedorahosted.org/cgit/initscripts.git/commit/?h=rhel6-branch&id=30483d5b4a4763e03dcc2462a4621b76568ab1b3 -> POST
Comment 13 errata-xmlrpc 2013-02-21 05:25:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0518.html

Note You need to log in before you can comment on or make changes to this bug.