Bug 71425 - Networking stack crashes with simple test.
Summary: Networking stack crashes with simple test.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: Ethernet drivers   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Gary Thomas
QA Contact: eCos bugs internal list
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-13 14:11 UTC by Gary Thomas
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 14:14:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple network server test (2.06 KB, text/plain)
2002-08-13 14:12 UTC, Gary Thomas
no flags Details

Description Gary Thomas 2002-08-13 14:11:43 UTC
Description of Problem:

Networking stack crashes with simple test.

Version-Release number of selected component (if applicable):

CVS

How Reproducible:

100%

Steps to Reproduce:
1. Build attached test program
2. Connect to server, port 4000
3. Crashes immediately

Actual Results:


Expected Results:


Additional Information:

Comment 1 Gary Thomas 2002-08-13 14:12:44 UTC
Created attachment 70326 [details]
Simple network server test

Comment 2 Gary Thomas 2002-08-13 14:14:34 UTC
This failure happens because the logical network driver is trying to take
a packet (string of mbufs) and send it to the physical layer.  This is done
via a simple data structure of limited size.   This test program easily causes
that data structure to overrun, which is currently treated as an error.

Comment 3 Gary Thomas 2002-08-13 15:57:51 UTC
Made size of scatter-gather list configurable, with a slightly larger default.


Note You need to log in before you can comment on or make changes to this bug.