Bug 714306 - subscription detail fields named the same thing
subscription detail fields named the same thing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-17 16:55 EDT by J.C. Molet
Modified: 2011-12-06 12:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:15:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
subdetails (338.33 KB, image/png)
2011-06-17 16:55 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2011-06-17 16:55:47 EDT
Created attachment 505350 [details]
subdetails

Description of problem:
In subscription-manager-gui, many of the accessibility handlers in the subscription details are named the same thing:  "Account".  This makes it difficult to tell the difference between the fields, and impossible to know which field value goes to which field.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.1-1.git.262.d10f44b.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start subscription-manager-gui
2. Subscribe to something
3. go to my subscriptions
4. try to read the subscription details through the accessibility api
  
Actual results:
See screenshot.

the shema is like this:
"Account" < tag for the field vale
"Account" < tag for another field falue
"Support Type:"  < tag for the field description
"Support Level:" < another tag for the field description

Expected results:
a shema is like this:
"Support Type" < tag for the field vale
"Support Level" < tag for another field falue
"Support Type:"  < tag for the field description
"Support Level:" < another tag for the field description

Additional info:
This blocks gui automation of this feature.
Comment 1 Bryan Kearney 2011-07-13 12:38:42 EDT
I can not run sniff, but I think this is fixed in 79d61cb0f4f7913ef70e45d838f5e33a091d614a in master.
Comment 3 J.C. Molet 2011-07-28 09:07:05 EDT
This works, the text fields are either named <fieldname>Text or just <fieldname>.  As read in from the api directly:

(pprint (filter #(not-empty (re-matches #"^txt\D+" %))
                (seq  (tasks/ui getobjectlist "Subscription Manager"))))


("txtSupportTypeText"
 "txtSupportLevelText"
 "txtProduct"
 "txtStartDate"
 "txtSubscriptionText"
 "txtAccountText"
 "txtContractNumber"
 "txtSubscription"
 "txtEndDate"
 "txtCertificateStatus"
 "txtdate-entry"
 "txtProvidesManagementText"
 "txtTextinSubscription")


Moving to VERIFIED

subscription-manager-gnome-0.96.4-1.git.65.a46fb73.el6.x86_64
Comment 4 errata-xmlrpc 2011-12-06 12:15:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.