Bug 71433 - Crash changing mouse type
Crash changing mouse type
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-13 12:32 EDT by Jay Turner
Modified: 2015-01-07 18:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-17 07:24:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2002-08-13 12:32:45 EDT
Description of Problem:
With redhat-config-kickstart-2.3.2-10, I can get the application to crash by
changing the mouse type and previewing the configuration file.  It doesn't
happen every time, and I haven't really been able to pin down the steps which
are required to reproduce it, but I've forced the crash a number of times.  What
is left on the screen after the crash is:

Gtk-ERROR **: file gtktextbtree.c: line 4509 (gtk_text_line_destroy): assertion
failed: (view != NULL)
aborting...
/usr/sbin/redhat-config-kickstart: line 4:  4346 Aborted                
/usr/bin/python /usr/share/redhat-config-kickstart/redhat-config-kickstart.py

Probably isn't that high of a priority unless someone knows off the top of their
head how to fix it.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Brent Fox 2002-08-13 14:32:45 EDT
I spent about 5 minutes beating this one over the head and I couldn't make it
crash.  Can you be more specific as to the steps required to break it?
Comment 2 Jay Turner 2002-08-14 12:32:53 EDT
Well, just made it happen again with redhat-config-kickstart-2.3.2-12. 
Basically what I do is change back and forth from Intellimouse (PS/2) to Generic
(PS/2) to "Probe for mouse" switching the 'emulate 3 buttons' checkbox from time
to time.  After every mouse type change, preview the config file.  This probably
isn't going to happen too often.  The only reason that I found it is I was
testing out all of the different variations, so I was previewing the file after
every change.  Most people are going to get it right the first or second time.
Comment 3 Brent Fox 2002-08-17 07:24:13 EDT
I've tested just about every mouse choice, toggling 3 button emulation, and
previewing permutation on two different machines and I can't reproduce this
problem.  My suspicion is that jturner eats too many Fruit Loops for breakfast
and it's affecting his mind.

I did find a bug with the mouse selection after all, though.  If the user
selected "No Mouse", but then checked 3 button emulation, the program would
write out:
"mouse --emulthree none" instead of "mouse none"

I'm not sure exactly how anaconda would interpret that, but I'd rather not find
out.  The right thing to do is probably make the checkbox insensitive if the
user selects "No mouse", but given the time I've decided to fix it in an easier
way.  The program just checks to see if no mouse was selected at Preview time
and if it was, it will not write out the --emulthree line.  

For the next release, we should probably replace all the Combo widgets with
GtkMenus like Havoc has suggested for other apps.

As far as the original bug, I don't know what else to do except close as
WORKSFORME.  There seems to be nothing I can do to reproduce it.
Comment 4 Jay Turner 2002-08-20 10:46:16 EDT
/me takes my Fruit Loops and goes home :-(

The fix for emulthree and no mouse is confirmed with
redhat-config-kickstart-2.3.2-16.

Note You need to log in before you can comment on or make changes to this bug.