Bug 714381 - Kernel 2.6.38.8 breaks Apple Magic Mouse and Trackpad
Kernel 2.6.38.8 breaks Apple Magic Mouse and Trackpad
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 716364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-18 15:27 EDT by YeOK
Modified: 2011-10-05 19:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: kernel-2.6.40.6-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-05 19:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description YeOK 2011-06-18 15:27:33 EDT
Description of problem:

After updating to kernel-2.6.38.8-32.fc15.x86_64 my Apple bluetooth Magic mouse no longer works.
 
kernel logs an error as follows;

Jun 17 17:55:18 yeok kernel: [   32.386970] magicmouse 0005:05AC:030D.0003: input,hidraw2: BLUETOOTH HID v0.84 Mouse [Apple Wireless Mouse] on 00:15:83:30:DF:7A
Jun 17 17:55:18 yeok kernel: [   32.386983] magicmouse 0005:05AC:030D.0003: unable to request touch data (2)
Jun 17 17:55:18 yeok kernel: [   32.398349] magicmouse: probe of 0005:05AC:030D.0003 failed with error 2

Reverting back to kernel 2.6.38.7-30.fc15.x86_64 makes the mouse works again. (With no error reports.)

Version-Release number of selected component (if applicable):
kernel-2.6.38.8-32.fc15.x86_64


How reproducible:


Steps to Reproduce:
1. Update to kernel 2.6.38.8-32.fc15.x86_64
2. Boot system using a bluetooth mouse (Magic mouse in my case.)
3. Try and navigate with the keyboard, because you have no bluetooth mouse. 
  
Actual results:
No mouse.

Expected results:
Mouse working. 

Additional info:
Is reported by another user on the fedora forums. http://forums.fedoraforum.org/showthread.php?p=1486630&posted=1#post1486630

I'm not sure what other information would be required, but I'd be happy to provide it when requested. 

Thanks. 
Alex Martin.
Comment 1 Gary Case 2011-06-20 09:49:40 EDT
I'm seeing the same problem on an Apple Magic Trackpad with the same resolution. Reverting to the old kernel makes things work again.
Comment 2 Stephen Fromm 2011-06-21 12:28:32 EDT
I see the same issue here on kernel-PAE-2.6.38.8-32.fc15.i686.
Comment 3 Chuck Ebbert 2011-06-24 08:53:08 EDT
Will be fixed in 2.6.38.8-35
Comment 4 Chuck Ebbert 2011-06-25 02:59:08 EDT
*** Bug 716364 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2011-07-06 21:00:15 EDT
kernel-2.6.38.8-35.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.8-35.fc15
Comment 6 Fedora Update System 2011-07-08 13:58:42 EDT
Package kernel-2.6.38.8-35.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.38.8-35.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.38.8-35.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-07-12 01:24:42 EDT
kernel-2.6.38.8-35.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Jeff Mitchell 2011-09-19 22:09:23 EDT
I can confirm that this is *not* fixed in Fedora 16 branched.
Comment 9 Jeff Mitchell 2011-09-20 14:43:59 EDT
Applying commit 23746a66d7 fixes this problem on F16 branched.
Comment 10 Josh Boyer 2011-09-20 14:51:10 EDT
(In reply to comment #9)
> Applying commit 23746a66d7 fixes this problem on F16 branched.

Erm... can you explain what you mean by F16 branched?  The latest F16 kernel is 3.1-rc6, which already has that commit...  So did the F16 Alpha release, given that 23746a66d7 was in 3.0-rc1.
Comment 11 Josh Boyer 2011-09-20 15:10:13 EDT
I'm going to look in my crystal ball and guess you meant 35d851df23b093ee027f827fed2213ae5e88fc7a, since 23746a6 was reverted by c3a492 later on.
Comment 12 Jeff Mitchell 2011-09-20 22:16:31 EDT
Nope, I meant 23746a6. I had to apply that patch to F16 3.1-rc5 to get the trackpad pairing properly.

I didn't see c3a492 and 35d851d; I'll have to look at them. Perhaps those are new in rc6, which I haven't updated to yet? If so, sorry for the noise.
Comment 13 Josh Boyer 2011-09-21 05:36:20 EDT
23746a6 was reverted before 3.0-rc4 by c3a492.  35d851d is a partial re-add of that upstream that is in -rc6, yes.
Comment 14 Chuck Ebbert 2011-09-26 09:30:17 EDT
This is not fixed on F15.
Comment 15 Chuck Ebbert 2011-09-26 09:38:51 EDT
Patch added, will be in the next release kernel.
Comment 16 Fedora Update System 2011-10-04 10:14:22 EDT
kernel-2.6.40.6-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.6-0.fc15
Comment 17 Fedora Update System 2011-10-04 23:58:50 EDT
Package kernel-2.6.40.6-0.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40.6-0.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.40.6-0.fc15
then log in and leave karma (feedback).
Comment 18 Gary Case 2011-10-05 13:37:48 EDT
I'm running kernel 2.6.40-6-0.fc15 and my magic trackpad works as expected. Thanks for the fix!
Comment 19 Fedora Update System 2011-10-05 19:58:35 EDT
kernel-2.6.40.6-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.