Bug 714431 - Empty LVM volume group leads to side effects on storage pools
Empty LVM volume group leads to side effects on storage pools
Status: CLOSED DUPLICATE of bug 782261
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-19 05:27 EDT by Simon Niechzial
Modified: 2012-01-24 20:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 20:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simon Niechzial 2011-06-19 05:27:41 EDT
Description of problem:

One or more empty LVM volume groups (read: no logical volumes inside) lead to side effects on other storage pools and VM creation.

Version-Release number of selected component (if applicable):
libvirt-bin                         0.8.3-5+squeeze1
libvirt0                            0.8.3-5+squeeze1 
python-libvirt                      0.8.3-5+squeeze1 
virt-manager                        0.8.4-8

How reproducible:
always

Steps to Reproduce:
1. Create a local or remote connection to a QEMU/KVM instance in virt-manager
2. Under "details -> storage" add an existing LVM volume group, e.g. "vg1" with path "/dev/vg1" selected from the dropdown. Make sure, the volume group contains no LVs
3. Make sure you have an ISO image accessible in a storage pool of type "dir"
4. Create a new VM named "test" with "local install media (iso-image or cdrom)"
5. Choose "use iso image" and browse to an image in the dir-storage
6. continue
  
Actual results:
virt-manager fails with "Checking installer location failed: Could not find media '/var/images/debian-6.0.0-amd64-netinst.iso'."

libvirt logs "error : virStorageBackendStablePath:1279 : cannot read dir '/dev/vg1': No such file or directory"

Expected results:
normal continuation of the VM setup process

Additional info:
The error message by libvirt is correct as you can see here:
 ls /dev/vg1
 ls: cannot access /dev/vg1: No such file or directory
The path is only created on first LV creation.
But I see no reason why this should affect the other storage-pools
Comment 1 Cole Robinson 2012-01-24 20:40:51 EST

*** This bug has been marked as a duplicate of bug 782261 ***

Note You need to log in before you can comment on or make changes to this bug.